Error While Runing FlatFile Service

Hello All,

I have freshly installed IS version 7.1 & i have installed Wmflatfile packages.
but while running the service pub.flatfile.convertToValue is throwing error.

i am suspecting that it’s not a code level problem
May be some java or jvm or jar file is missing?

IS configuration:-

Java Version 1.5.0_12 (49.0)
Java VM Name Java HotSpot™ Server VM
Java Build Info 1.5.0_12-b04, mixed mode
Java Vendor Sun Microsystems Inc.
Java Home C:\webMethods71\jvm\win150\jre

Updates None
Build Number 149
SSL Strong (128-bit)

WmFlatFile packages has been partially loaded.

pub.flatFile:getSupportedEncodings java.lang.VerifyError: (class: pub/flatFileImpl, method: convertToValues signature: (Lcom/wm/data/IData;)V) Incompatible argument to function
pub.flatFile:convertToValues java.lang.VerifyError: (class: pub/flatFileImpl, method: convertToValues signature: (Lcom/wm/data/IData;)V) Incompatible argument to function
pub.flatFile:convertToString java.lang.VerifyError: (class: pub/flatFileImpl, method: convertToValues signature: (Lcom/wm/data/IData;)V) Incompatible argument to function

Have a look on my server.bat file May be i am missing something


i have installed latest jdk 1.6 & change extended setting in Admin page restarted IS but still getting same error partially loaded with missing class files
add below setting

watt.server.compile=C:\Program Files\Java\jdk1.6.0\bin\javac -classpath {0} -d {1} {2}
watt.server.compile.unicode=C:\Program Files\Java\jdk1.6.0\bin\javac -encoding Unico



what are the inputs pub.flatfile.convertToValue? Can you share your flowservice?

Sure shahid,

i have installed Wmflatfile Sample packages wch u can find in Advantage site sample utilities.

1 pub.flat.getfile (input nothing & output has document)
in pipeline set file name & loadas byte

2 pub.flatfile.convertToValue(map byte to ffdata)
set ffschema name validate true & return error both

i believe it not a code level issue some issue in jvm or java class file .
as i have told recently i have installled jdk 1.6 & set path in extend setting in admin page but still getting same error.


Which package is partially loaded ? Is it WmFlatFile or WmFlatFileSamples package ?

Flatfile samples package which you have downloaded, is it for 65 or 71 version ?

In your extended settings, point the jvm that comes up with webMethods… Restart the server to see if the package is loading properly or not.

watt.server.compile=E:\webMethods712\jvm\win150\bin\javac -classpath {0} -d {1} {2}
watt.server.compile.unicode=E:\webMethods712\jvm\win150\bin\javac -encoding Unicode -classpath {0} -d {1} {2}


It’s WmFlatFile packages partially loaded with v 6.5 (My IS v 7.1)

i have pointed jvm as per suggested & restarted the IS but still i am getting same error

watt.server.compile=C:\webMethods71\jvm\win150\bin\javac -classpath {0} -d {1} {2}
watt.server.compile.unicode=C:\webMethods71\jvm\win150\bin\javac -encoding Unicode -classpath {0} -d {1} {2}

catch there is My WmEDI v 6.5.2 package is too partially loaded with error

wm.b2b.edi.tradacoms:convertToValues java.lang.NoClassDefFoundError: com/wm/ff/parse/interfaces$Totalar
wm.b2b.edi.tradacoms:convertToString java.lang.NoClassDefFoundError: com/wm/ff/parse/interfaces$Totalar

Dependency packages

WmEDIforTN ,
WmEDIsamples ,


Is 1.6 supported by 7.1.2? I’m not sure that it is.

It sounds like the installation is either incomplete, or there are conflicting libraries on the classpath.