Getting error when compiling java service

Hi All,
I am using wM7.1.2. When i am trying to compile a java service getting error which is as below :

cannot access com.wm.util.Values
bad class file: C:\webMethods712\common\lib\wm-isclient.jar(com/wm/util/Values.class)
class file has wrong version 49.0, should be 48.0
Please remove or make sure it appears in the correct subdirectory of the classpath.
import com.wm.util.Values;

I already have wm-isclient.jar file which is of 3.34 MB in size. I tried to google to download new versioin of the jar file but could not able to locate. Kindly share me if anyone knows url from where i can download wm-isclient.jar file.


Hi RP,

Can you share the piece of code you are trying to compile and your requirement.

And also in wM 7.1.2 in the file system I don’t see the path C:\webMethods712\common\lib\ (Not sure if this is correct as I am unable to locate this on my install)

Is the wm-isclient.jar copied from other version of WM? It seems that your jar is compiled with JDK 1.5, but 7.1.2 needs a 1.4 version. You can download it from my dropbox.

@ Mahesh: I am getting this error with any java service when i am trying to compile.

@ Wang : I copied file but still experiencing the same error.

Any other suggestions to come out of this issue.


What’s the value of Extended Setting watt.server.compile in your environment?

Let me know your java version and the extended settings on IS?


As part of extended setttings, i have below details :

watt.server.compile=C:\webMethods712\jvm\win142\bin/javac -classpath {0} -d {1} {2}



Your developer and IS should have of same version. Please let us know the IS and Developer/Designer versions.



@ RP,

Just a thought, can you try installing JDK 1.5 and set the class path in extended settings as below

For Eg:
watt.server.compile=C:\Program Files\Java\jdk1.5.0_09\bin\javac -classpath {0} -d {1} {2}
watt.server.compile.unicode=C:\Program Files\Java\jdk1.5.0_09\bin\javac -encoding Unicode -classpath {0} -d {1} {2}

I got wm-isclient.jar file which is of 3.7MB. After copying this jar to lib, its working absolutly fine. Thanks guys for your valuable inputs.



Finally closed

3.7MB(3,877,399 bytes) is used for Version 8.x, you sure you are using 7.1.2?

Hi Wang,

Yes, i am using wM7.1.2 version but still this jar file is working :slight_smile: