Error while posting idoc to SAP

Hi Folks,

I am facing a strange issue while posting idoc to SAP.
Error : [SAP.115.9561] Notification error: - [ART.117.4002] Adapter Runtime (Adapter Service): Unable to invoke adapter service
[SAP.103.9117] WmSAP Adapter: Error during client call in service “ - Unable to get metadata for ZEMPLCOMMUNICATION_CHANGE01: SEGMENT_UNKNOWN”: “{1}”

When ran service in debug mode, this is what i captured in server.log
JCoClient.execute (IDOCTYPE_READ_COMPLETE) threw an ABAP exception: (126) SEGMENT_UNKNOWN: SEGMENT_UNKNOWN Message 257 of class EA type E, Par[1]: Z1ZEMPLCOMMUNICATION_CHANGE, Par[2]: 700

Please find my analysis,

  1. I am able to post idoc in SAP DEV system but not on SAP QUALITY system
  2. When webMethods DEV is pointed to SAP QUALITY then i am able to post idoc
  3. When webMethods QUALITY is pointed to SAP DEV system then same Error
  4. I am able to do Lookup from SAP Adapter page and able to display IDOC structure
  5. I compared the SAP Adapter version , JCO version and they are same. (Please find attachments)

Can anyone please help me?

Did i forget anything else to check?

Did you also compare the IS and developer fix?

Hi Vikas,

I compared the environment between wM DEV and wM QUALILTY and they are same.

We are using
JVM version : 1.6.0_27
IS Version : Version
Updates : IS_7.1.3_Core_Fix17

Just to know : SAP DEV and SAP QUALITY are ECC 6 version

Let me know what additional information you need so that you can quickly assist me !!

Didi you check developer or designer fix (whatever you are using for posting the data to SAP)?

Hi Vikas,

We are not using designer and by the way how come Developer fix is related to the issue i dont understand.

we are using 7.1.3 version across all Environments.

Hi Sudheer,
Your confusion is right. But in past I’ve seen some issues which were weird and got solved after applying patch to developer. Can not recall those issues but when i come across such issues then I check once if any developer fix is there.
Anyways you can log a call to SAG support. I do not get any idea other than this for your issue.

I would say please check the Empower KC and search on the IS error codes you are getting
and review the results.

for example:




There are some search hits for the above.