Error while enabling JDBC Adapter Polling notification


I’m trying to work with JDBC Adapter notification.

When i’m trying to enable JDBC Adapter Polling notification it gives the below error.

[ART.116.3038] Adapter Runtime (Notification): Error in Notification Callback:enableCallback notification DB:insertNotification.
[ADA.1.316] Cannot execute the SQL statement “Unable to get metadata.”. "
(17008) Closed Connection"
Closed Connection

Adapter connection details are,

Connection Type JDBC Adapter
ConnectionPackage Name MyPlayground

Connection Properties

DataSource Classoracle.jdbc.pool.Oracle
DataSource serverName wjnjinbgmemp1
user scott
password *****
databaseName ORCL
portNumber 1521
network Protocol tcp
Other Properties driverType=thin

Connection Management Properties

Enable Connection Pooling true
Minimum Pool Size 1
Maximum Pool Size 10
Pool Increment Size 1
Block Timeout (msec) 1000
Expire Timeout (msec) 1000
Startup Retry Count 0
Startup Backoff Timeout (sec) 20

Please help me out.



Install latest JDBC Fix and check.
I think this will help you.



This is becoz of already existing some notification objects while enabling… its trying to recreate them…

Run “pub.pollingNotificationUtils:getDatabaseObjectsForNotification” giving your full notification name it will delete all existing object …

Try to Enable the notification; it will work…

if not restart the IS after doing above steps…


Run “pub.pollingNotificationUtils:dropDatabaseObjects” not the “pub.pollingNotificationUtils:getDatabaseObjectsForNotification” we need to drop the existing object, with above we can see objects created…



which version of JDBC adapter are you using.

webMethods has already provided a fix for this. Try searching this in on advantage, I am sure you will get something usefull


Hi All,

Thanks for your swift replies.

I tried to run “pub.pollingNotificationUtils:dropDatabaseObjects”

The above service ran indefinitely!!!

Tried this too… “pub.pollingNotificationUtils:getDatabaseObjectsForNotification”

But it did not fetch any result!

I searched for fix and found some fix related to JDBC.

But even before installing the fix it is working(notification can be enabled)

In the mean while i have re installed oracle on my machine.

I would like to know what might have caused the problem and how it solved!


If its Oracle XE … webMethods insert, update and delete notification will not work but basic notification will…