Error while calling remote webservice

Hi All,

I have received WSDL from client and consumed it in webmethods 8.2 .

while calling the remote service by using connector I am getting below error

interface name: soap11
service name: TEST
Parameter “location” is not optional

but I consumed same WSDL in soap UI and getting positive response.

Please help me to resolve .

What does the WSDL actually do? If possible can you share it…

I see it says location is not optional and I guess it should be mandatory…

Hi Mahesh,

Thanks for your response .

I am afraid I can not share my WSDL.

The below error I am getting in server log file

–Requst xml

<?xml version="1.0" encoding="UTF-8" ?>

<SOAP-ENV:Envelope xmlns:SOAP-ENV=“http://schemas.xmlsoap.org/soap/envelope/” xmlns:SOAP-ENC=“http://schemas.xmlsoap.org/soap/encoding/” xmlns:xsd=“http://www.w3.org/2001/XMLSchema” xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance” SOAP-ENV:encodingStyle=“http://schemas.xmlsoap.org/soap/encoding/”>
<SOAP-ENV:Header xmlns:SOAP-ENV=“http://schemas.xmlsoap.org/soap/envelope/”></SOAP-ENV:Header>SOAP-ENV:Body
<ser-root:getStatus xmlns:ser-root=“urn:TEST” SOAP-ENC:root=“1”>

CLCLL0301
1
2

</ser-root:getStatus>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>

–Response xml
interface name: soap11
service name: TEST
Parameter “location” is not optional

I removed the id tag in location field and then posted the same request in Soap UI, then I am getting positive response


Kindly let me know how to remove id tag in the input document after consuming it in Webmethods developer 8.2

Hi Charles,

With Ref: http://www.w3.org/TR/wsdl#_Toc492291093,

The location attribute specifies the base URI for the port. The value of the attribute is combined with the values of the location attribute of the http:operation binding element.

location should contain the URI, the complete address, not the shorter one as shown in attached error.

HTH.

Thanks,
Rankesh

Hi Rankesh,

Thanks for your response.

location is not an attribute its a complex type in the wsdl.

Please find the sample wsdl attached.

correct me if I am wrong.

sample.wsdl (2.29 KB)

Hi Charles,

My apologies, I missed that.

I am able to import the sample wsdl in wm 8.2.

It seems you need to update your IS to latest patches. What is your is_core_fix?

Thanks,
Rankesh

Hi Rankesh,

This is latest core fix “IS_8.2_SP2_Core_Fix7”.

I am able to consume the wsdl but while calling I am getting above mentioned error.

Please help me how to proceed further.

Hi Charles,

I found no issue while importing the attached WSDL.

The latest fix is : IS_8.2_SP2_Core_Fix13 - IS_8.2_SP2_Core_Fix13

Please get the latest fix(es) from empower. For your reference I am attaching the screenshot.

Thanks,
Rankesh
IS Latest Core Fix.PNG

Thanks Rankesh,

I have referred the webmethods SOAP developer’s guide and found a solution .

we need to set “watt.server.SOAP.useMultiReference=false” in the extended setting ,default is true.

It removes the id and href attribute for parameter.

Now its working fine .

If I am facing any further problem I will let you know.

Charles,
Thanks for giving your update on the resolution.

Good day :slight_smile: