Error publishing task interface to MWS server

[POP.003.0025] {0} cannot view the content of {1}.; nested exception is:
com.webmethods.portal.PortalException: [POP.003.0025] {0} cannot view the content of {1}.
[POP.003.0025] {0} cannot view the content of {1}.; nested exception is:
com.webmethods.portal.PortalException: [POP.003.0025] {0} cannot view the content of {1}.

Any ideas why I’m getting this error? I’ve published this task interface before but now it is not working. I rebuilt my workspace in designer and that didn’t help either (though it usually does).

Thanks for any help.


http://webmethodssag.blogspot.com

Finally searched and figured it out. You have to be logged in as SysAdmin to publish a task. I had lost the login when I had to rebuild my workspace in Designer.


http://webmethodssag.blogspot.com

Hi,
I am deploying an RMA application into MWS8.0
The application do appear under busniess rules in MWS.But the problme is when i clik on the application it gives error as
com.blazesoft.repository.base.NdRepositoryRuntimeException: Could not find class 'com.microsoft.sqlserver.jdbc.SQLServerDriver
Please can anyone help me out in resolving the error.I guess we need to put sqljdbc4.jar but where exactly in MWS is abig question in my head:-(((

We just did this as well. You need to load the same SQL driver on your MWS server as you used in Blaze to connect to the database repository.

Put it in your MWS/lib/ext directory.


http://webmethodssag.blogspot.com

Thanks Willaims for the reply.Please can you let me know how did you figure it out in which directory we have to put as i was trying to find out in exactly which directory the jar file should be put.

Thanks

As a java developer it is a standard practice to put any libraries in the lib/ext directory for all kinds of java apps. Since webMethods is java backed it just made sense.


http://webmethodssag.blogspot.com

I actually put the files in lib/et directory and restarted the server but still it didnt worked out.Anything else do u think i am missing??

lib/et or was that a typo? It should be lib/ext

Here’s the complete linux path on my machine.
/apps/softwareag/MWS/lib/ext

I copied jtds-1.2.4.jar into that directory, restarted the MWS server and then it worked.

sorry that was a typo.The jar file specified by you doesnt contain the class file com.microsoft.sqlserver.jdbc.SQLServerDriver about which i am getting missing class error.
how will it help me out resolving the missing SQLServerDriver class error

Sorry for the confusion. That is the JTDS driver. It looks like you are using the MS driver, so you’d need to install the files that come from here:
http://www.microsoft.com/downloads/en/details.aspx?FamilyID=a737000d-68d0-4531-b65d-da0f2a735707&displaylang=en

Looks like there are 3 files:
Set your system CLASSPATH variable to include the following entries:

  • \Your installation path\Lib\Msbase.jar
  • \Your installation path\Lib\Msutil.jar
  • \Your installation path\Lib\Mssqlserver.jar

(from http://support.microsoft.com/kb/313100 )

Hope that helps.


http://webmethodssag.blogspot.com

Hi,
The Sqljdbc exception got resolved but i am getting this new excpetion.
I created RMA application with a template and deployed it into MWS.After deploying to MWS i created a new Rule Instance ,provided the place holder values,saved it and checked in it.Now when i click on Deploy in the Toolbar it doesnt get deployed and instead throws Null pointer Excpetion as follows:
java.lang.NullPointerException
at org.apache.jsp.deploy_jsp._jspService(deploy_jsp.java:563)
at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:93)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:373)
at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:470)
at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:364)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:511)
at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:390)
at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:182)
at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:765)
at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:418)
at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:230)
at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
at org.mortbay.jetty.Server.handle(Server.java:326)
at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:542)
at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:923)
at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:547)
at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:212)
at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:404)
at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:409)
at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:451)

Can you please help me in resolving this issue …stucked for long time in this.
Thanks
Alok Agarwal

We never did get the RMA implementation working, so we just abandoned it.


http://webmethodssag.blogspot.com