error message when trying to save serice flow in designer

Hello,

when we try to make changes on a service flow in designer and when you want to save the changes made:
The IS refuses to save the changes and return an error message:

See attached screen shot of : simple service with map added

webmethods version : 8.2.2
system redhat

thanks in advance

Hi, is there enough space on hard disk?

Konrad

Does this happens for every service you save on this IS or it’s just with this service in question?

HTH,
RMG

Do we know what did you set/map as part of map step ? I hope you got this error only for this service, did you ?

Thanks,

Hello,
thank for your answers :slight_smile:

yes there is enought space disque
yes this happend to any serice flow we want to make change on it

i got this error for all services new and old ones , and its new map( no pipe line mapping set)

thanks in advance

Hello,

Do you have any idea or do you have had a similar problem

thanks in advance

Try the below steps to see if issue resolves

1> Restart the designer
2> Recreate the work-space
3> Have the latest designer fixes installed
4> If it is has worked earlier, try to re-install the designer alone.

Hi,

additional step to try:

  • Shutdown Designer
  • Open a Command Prompt Window
  • navigate to where Designer (eclipse.exe) is installed
  • run “eclipse.exe -clean”

The next time you want to start Designer this can be done in the normal way.

Regards,
Holger

Hello ,

i reinstall the designer and still getting same error :

this happend only in the production server and not in the dev server .

i export the prod packages import them in dev environment and i can change services using designer in the dev environment

Thanks in advance .

Hello,
I opened the WMERROR file after modification, here is the error message :

WMERROR 3124ef30-1777-11e6-9e1f-f2111f810eea 3124ef30-1777-11e6-9e1f-f2111f810eea db48662f-ae3c-417d-a6d8-f52fd2aa95d2 localhost.localdomain:5555 2016-05-11T12:52:17.443Z 2016-05-11T12:52:18.93Z java.lang.ClassCastException: [Ljava.lang.Object; cannot be cast to [[Ljava.lang.String;
Caused by: java.lang.ClassCastException: [Ljava.lang.Object; cannot be cast to [[Ljava.lang.String; java.lang.ClassCastException: [Ljava.lang.Object; cannot be cast to [[Ljava.lang.String;
at com.wm.lang.ns.NSService.setValues(NSService.java:758)
at com.wm.app.b2b.server.FlowSvcImpl.setValues(FlowSvcImpl.java:935)
at wm.server.nsimpl._putNode(nsimpl.java:5956)
at wm.server.nsimpl.putNode(nsimpl.java:5122)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at com.wm.app.b2b.server.JavaService.baseInvoke(JavaService.java:443)
at com.wm.app.b2b.server.invoke.InvokeManager.process(InvokeManager.java:643)
at com.wm.app.b2b.server.util.tspace.ReservationProcessor.process(ReservationProcessor.java:41)
at com.wm.app.b2b.server.invoke.StatisticsProcessor.process(StatisticsProcessor.java:44)
at com.wm.app.b2b.server.invoke.ServiceCompletionImpl.process(ServiceCompletionImpl.java:243)
at com.wm.app.b2b.server.invoke.ValidateProcessor.process(ValidateProcessor.java:51)
at com.wm.app.b2b.server.invoke.PipelineProcessor.process(PipelineProcessor.java:171)
at com.wm.app.b2b.server.ACLManager.process(ACLManager.java:276)
at com.wm.app.b2b.server.invoke.DispatchProcessor.process(DispatchProcessor.java:30)
at com.wm.app.b2b.server.AuditLogManager.process(AuditLogManager.java:363)
at com.wm.app.b2b.server.invoke.InvokeManager.invoke(InvokeManager.java:547)
at com.wm.app.b2b.server.invoke.InvokeManager.invoke(InvokeManager.java:386)
at com.wm.app.b2b.server.ServiceManager.invoke(ServiceManager.java:244)
at
com.wm.app.b2b.server.comm.DefaultServerRequestHandler.handleMessage(DefaultServerRequestHandler.java:119)
at com.wm.app.b2b.server.HTTPMessageHandler.process(HTTPMessageHandler.java:160)
at com.wm.app.b2b.server.HTTPDispatch.handleRequest(HTTPDispatch.java:186)
at com.wm.app.b2b.server.Dispatch.run(Dispatch.java:…wm.server.ns:putNode


I cheked same node.ndf file of service flow in the production server and dev server and i found difference see attached the difference :

Thanks in advance

Hi Omar,

can you check the Fix level between Dev IS and Production IS please?

Looks like you are missing some Fixes on one of them.

Regards,
Holger

I agree with Holger ( please check the fix levels ), also check is the environment set-up identical in dev n prod ?

Thanks,

Hello,

for production env:
These fixes exist in the specified installation directory
Install Directory:/opt/webmethods

Installed? Fix Name


  1. [I] All fixes
    
  2. [I]   Adapter Runtime
    
  3. [I]     Adapter Runtime 8.2 SP2 Fix 3
    
  4. [I]   Adapters
    
  5. [I]     AS 400 Adapter 6.0.1 Fix 7
    
  6. [I]   Asset Build Environment
    
  7. [I]     ABE_8.2_SP2_Fix4
    
  8. [I]   Common Library
    
  9. [I]     SCG_8.2.2_Terracotta_Fix4
    
  10. [I] ABE_CL_8.2_SP2_Fix9
  11. [I] Integration Server
  12. [I] DEP_8.2_SP2_Fix7
  13. [I] IS_8.2_SP2_Core_Fix12
  14. [I] Flat File 8.2 SP2 Fix5
  15. [I] My webMethods Server
  16. [I] MWS_8.2_SP1_Fix16
  17. [I] Trading Networks
  18. [I] TNS_8.2_SP2_Fix23
  19. [I] Trading Networks Portal
  20. [I] TN_8.2_SP2_MWS_Fix20
  21. [I] Web Services Stack
  22. [I] WSStack 8.2 SP2 Fix12
  23. [I] eStandards
  24. [I] EDI Module 8.0 SP1 Fix 24
  25. [I] EDIINT 8.0 SP1 Fix 10

for developpment env:
These fixes exist in the specified installation directory
Install Directory:/fcdx90/webmethods_RC

Installed? Fix Name


  1. [I] All fixes
    
  2. [I]   Adapter Runtime
    
  3. [I]     Adapter Runtime 8.2 SP2 Fix 3
    
  4. [I]   Adapters
    
  5. [I]     AS 400 Adapter 6.0.1 Fix 7
    
  6. [I]   Asset Build Environment
    
  7. [I]     ABE_8.2_SP2_Fix4
    
  8. [I]   Common Library
    
  9. [I]     SCG_8.2.2_Terracotta_Fix4
    
  10. [I] ABE_CL_8.2_SP2_Fix9
  11. [I] Integration Server
  12. [I] DEP_8.2_SP2_Fix7
  13. [I] IS_8.2_SP2_Core_Fix12
  14. [I] Flat File 8.2 SP2 Fix5
  15. [I] My webMethods Server
  16. [I] MWS_8.2_SP1_Fix16
  17. [I] Trading Networks
  18. [I] TNS_8.2_SP2_Fix23
  19. [I] Trading Networks Portal
  20. [I] TN_8.2_SP2_MWS_Fix20
  21. [I] Web Services Stack
  22. [I] WSStack 8.2 SP2 Fix12
  23. [I] eStandards
  24. [I] EDI Module 8.0 SP1 Fix 24
  25. [I] EDIINT 8.0 SP1 Fix 10

Thanks in advance

Hi Omar,

please provide your Designer version and the Fixes applied to it.

Latest Version I know of is Designer 8.2.2 with SP3 for Service Development.

Latest Fixes:

  • ESB_8.2_SP3_Fix15 (Service Development)
  • DES_8.2_SP2_Process_Fix33 (Process Development)
  • DES_8.2_SP1_CAD_Fix10 (UI Development)

Can you check if you can work with Developer in this case?
8.2 should still have a Developer available.

Regards,
Holger

Hello,

sorry for the delay !

you were right the - ESB_8.2_SP3_Fix15 (Service Development) solved the problem ( it was designer issue not is issue)

Thank for all

2 Likes

Thanks Omar for updating back the thread with what you found the resolution.

Thanks,