Error message on Input fields - positioning of cursor

On a screen with input fields, where these input fields are defined as Numeric (.) and the maxlength is specified in the property, the following happens when invalid data is entered into the field:

A pop-up box appears informing the user that “one or more fields do not
contain valid entries. The respective fields are marked with red color, please check you entries and correct them as necessary” with an “OK” and “CANCEL” option.

When the user click on “OK”, the field resets to the initial value and the cursor jumps to the next field. If the field where incorrect data was entered was the last field on the screen, the cursor jumps to the first field on the screen that can be filled.

When “CANCEL” is pressed (Have to click it twice), the field retains the incorrect value entered and the cursor jumps to the next field. If the incorrect field is the last one one the screen, the cursor stays on the incorrect field.

Regardless of what the user chooses: “OK” or “CANCEL”, we want the cursor to return to the field where the incorrect value was entered.
How do you do this, any ideas?

Hi Niki,

If you specify a maxlength, then per default the focus will change to the next field, when the maxlength is reached.
If you don’t want this default behavior: Set the autotab prperty of the FIELD control to false.

For invalid values entered into the field:
When pressing “CANCEL” the focus must be set back into the “error-marked” field. When trying to leave the field with an invalid value the popup must appear again. If this does not happen in your installation please enter a support request for this.

When pressing “OK” the field is reset with the last valid value. Depending on maxlength and autotab setting the focus is either still in the field or set to the next field.

Best Regards,