Error in subversion configuration

Hi All,

We are trying to implement the version control system for the webMethods Developer.

The following steps i followed:

SVN installed in the UNIX on which my IS is installed.

1.>svnadmin create home/unixusername/repos
2.>vi authz.config
Administrator = rw
admin =rw
3.>vi passwd.config
Administrator =manage
4.>vi svnserve.conf
anon-access = none
auth-access = write
password-db = passwd
5.>svn import file:///home/unixusername/repos -m “Intial Import”
6.>svnserve -d
7.>svn co svn://hostname/home/unixusername/repos

  1. In webMthods 8.2 IS,
    select Version Control System=Subbersion
    sub version repository location =svn://hostname/unixusername/repos

when i give svn location i am getting error " Error in subversion configuration"

but From TortoiesSVN i am able to connect Repository
Repo-Browser URL : SVN://hostname/home/unixusername/repos

Please help me to resolve.

Thanks in advance

Please check this article:

webMethods Integration Server - Error in subversion configuration.

KB #: 1737514 Operating System Family: PC
Product: webMethods Integration Server (PIE) Operating System: All
Last Updated: 12-JUN-2012

The customer is not able to connect to subversion.


Please have the customer verify that they have the WM_HOME variable set in the server.bat.

  • Shutdown IS.
  • Add -DWM_HOME=%IS_DIR% in the JAVA_OPTS for Windows or
    -DWM_HOME=${IS_DIR} for UNIX.
  • Start IS using server.bat(sh).

Also please check the Empower KB and search with keyword " Error in subversion configuration" there are tons of results came up.



Thanks for the response.

I don’t have access to the Empower.

I have checked the file as you suggested my configuration were same.


I created a repository inside the IS/packges location and tried to access from IS giving the following URl

but still I am getting same error.

SVN Version 1.3.2

Kindly advice me how to proceed further.

Please reach out to SAG support since this is on 8.2.x issue.


Finally i configured the SVN repository URL in the IS.

but, When i checkout the service from developer I am getting below error

Default/Default:test: [ISS.0132.9117] error running command [svn, lock, --username, xxx, --password, ********]; exit value: 1; output: [svn: ‘/apps/unixusername/instance/IntegrationServer/packages/Default/ns/Default/test’ is not a working copy]

Please help me to resolve.

“… is not a working copy” is standard subversion behavior. If you use subversion you need to check in your directory and then make a complete fresh checkout of the dir you are working on. Just inserting the SVN server URL in the IS admin console is not sufficient. The webMethods product guide describes what to do for setting up versioning with subversion on the IS side. If you follow the instructions there carefully this error should not occur.

Thanks for your reply.

Its working for me now .

This is where I went wrong, once I imported all the packages into subversion, I forgot to move the packages into some location.

I followed these steps and its working fine.

1.> cd …/IntegrationServer/packages
2. >svn import file:///home/unixusername/repos -m “Intial Import” /Importing all the packages into repository/
3. >mv packages …/IntegratonServer/replicate/salvage /*move/archive the packages into some location */
4.>svnserve -d
5.>svn co svn://hostname/home/unixusername/repos /checkout the repository/
6.>restart the IS
7.> In IS Consol page
select Version Control System=Subbersion
sub version repository location =svn://hostname/unixusername/repos /repository location/
8.> restart the IS

But the performance very slow. Its taking so long to checkout and checkin.

Glad to hear it resolved now :smiley: …and thanks for sharing the update info in the thread back.

Hi All,

I configured subversion successfully and I am able to check out and check in the existing services.

But when I try to create a new flow service, I am getting below error.

Could not create ‘SVNTest:Untitled’. [ISS.0132.9117] error running command [svn, lock, --username, Administrator, --password, ********]; exit value: 1; output: [svn: ‘flow.xml’ is not under version control]

Kindly help me to resolve.

Can you please check on this resolution?


The customer was using the proper 1.6 version of the SVN server, but found out that they were using a 1.7 version of an SVN client on the Integration Server. This 1.7 version was replaced with Collabnet Subversion Client 1.6.19 and everything works fine.


Thanks for the information @rmg
Sorry for the delayed response.
I am having same version of svn server & client .
I have tried following commands in my UNIX box.

1.>svn --version
svn, version 1.3.2 (r19776)
2.>svnserve --version
svnserve, version 1.3.2 (r19776)
3.>svnadmin --version
svnadmin, version 1.3.2 (r19776)

So I assume I need to install latest SVN in my machine,is my assumption correct?


Please get in touch with Pradeep, who worked extensively in designing SVN solutions on webMethods.



i will suggest avoid using WmVCS if you can. it is deprecated and have lot of issues.

Try looking at other solution like Designer workstation.

1 Like

Yes a good note to consider it that option as well…

Hi Charles,

Is it necessary to have IS,SVN server and SVN client on same machine for webMethods SVN to work?

Hi All,

Getting below while configuring svn repository location on IS

ISS.0132.9117] error running command [svn, mkdir, -m, Initial Import,]; exit value: 1; output: [svn: Server sent unexpected return value (405 Method Not Allowed) in response to MKCOL request for ‘/svn/webMthods_SVN/!svn/wrk/5362287d-f224-402a-acb4-80e69c4bfb53/packages’]

Any clue what exactly that could be?

Best Regards,

Hi Ankit,

I don’t have idea about whether IS,SVN server and SVN client need to be on same machine.

In my case they are on same machine.

I have followed these steps and it was working fine.


As we have a working scenario better have it all on the same maching and worth a try.

If this is not possible in your env…open a ticket with SAG support and they can assist and troubleshoot a alternative solution.


The Subversion server itself definitely does NOT have to be on the same server as the IS. In fact, in most companies, that will not be the case. The Subversion client DOES since it needs to be loaded where the files that you’re trying to check-in and check-out are present.

By the way, as others have indicated here, I would refrain from using WmVCS-based solutions. When it comes to VCS integration, your best bet is doing local development, where each developer has the files loaded locally and they can each use whatever plugin they like. Designer Workstation is the most common option here.

If that’s not possible, I would still avoid WmVCS and opt for a more “hands on” approach where developers issue SVN client commands directly. WmVCS has a number of issues, which is one reason why Software AG moved away from it.


Hi Charles Antony,

You said, finally you have configured SVN repository URL in IS Console…Could you tell us what went wrong earlier? as We are also getting the same error “Error in subversion configuration” while configuring repository URL on WMVCS package.