EDI segment delimiter

I have to EDI document in this format
ST8100001~
BIG2003081335249946200308128380811027 ~
ITD0130Net 15 Prox~
IT15EA19.5UP*73390510009~

When I place ~ as segment delimiter new line doesn’t appear anymore.
But I want both ~ and new line as segment delimiter.
Please suggest.

Thanks
johnson

We can accomplish your problem using the following,its tricky though

After you set the ~ as delimiter invoke the following:

pub.string:tokenize (set delim= ~)which gives out valueList) then
pub.string:makeString (map the above valueList and set the delim= ~ and also under that just enter the cursor (it gives the newline character)and close the setValue box)

finally it gives the output as you required.

ST8100001~
BIG2003081335249946200308128380811027 ~
ITD0130Net 15 Prox~
IT15EA19.5UP*73390510009~

see the sample package attached with the above mentioned logic.

EdiwithTwoDelim
Test.zip (5.1 k)

HTH,

Hi johny1212,

I have had problems when such data was presented to other B2B Application I was interacting with, as they could not handle this additional CR.

My question is why?
Is your requirement for processing or viewing purposes?
Is this inbound to you or outbound from you?

Having dual Segment delimiters is very unusual.

Johny,

If your requirement is just for viewing purposes then use the UltraEdit tool.

Even i have not seen any EDI document having with dual segment delimiters,but still i posted the logic above to solve your problem with in webmethods.

Regards,

Thanks RMG! Your Solution works

Hi,

I have another problem. In the document, which I receive will contains no delimiter. Neither record nor field delimiter. TN is not recognizing this. his Document type is X12 2040 850. If you have any solutions please suggest.

Thanks,
Madhu .

The EDI document should come with some Delimiters,otherwise its an invalid document.Convey your partner to send it correct.

HTH,

Hi RMG,

Its a fixed length records. Can you please suggest in this regard.
Thanks,
Madhu M.

Madhu

Create a new post when you are posting a new query.

Treat your document as a flat file and proceed. You have to develop or obtain the template and schema if required.

Regards

Sreedhar

Madhu,

If it’s fixed length it’s not ANSI EDI.
They’re just calling the file an EDI file.
Like Sreedhar said treat it as a flat file, create your schema and away you go.
Tell the schema it’s a fixed length record and you delimiter issue will be gone.
HTH

Madhu,

Please follow the above suggestions.It will work.

Regards,

One reason you might want the CR in there is for a system that does not handle wrapped data. It is unusual but I have had the request before from trading partners.

Dawn it still wouldn’t be fixed length. EDI is variable length.
If he’s getting blocked data then that’s a different issue.
As in blocked at 80 characters in a Bysnc connection from GXS or some other VAN.
In that case he can tell the VAN to send it as streamed data or write a pre-processing service to strip out CR/LF (0D/0A) and then pass the un-blocked data back to TN.

Chris,
The request could actually be for both to have CR and fixed record length at 80. I have had a variety of requests over the years and some companies don’t know how to handle the streamed data. I guess I missed in the thread where the fixed record length requirement was stated but in this case it would be padded with blanks to complete the 80 character fixed length requirement. All I was intending with my post is to note that I have had this request before and the reason someone might request this.
Thanks,
Dawn

Dawn,

I wasn’t trying to belittle you point I just don’t understand how an ANSI EDI file can be fixed length to 80 characters. That would mean you are padding the last field in every segment. I understand it can be blocked.

Chris,
No problem I didn’t think you were belittling anything. I get a lot of requests for weird things (I’ve been doing EDI since about 1985) and I agree the fixed length and padding with blanks is weird! I guess all the variety of issues that come up with integrating systems is why we have job security :o) As long as you make it work they keep coming back for more.
Thanks,
Dawn

Hi,

I am using a Fixed Length record in a flatfile to send a confirmation back to the client, but the client needs a CRLF character at the end of each record. The fixed length is 550.

I tried to put a \n at the 548-549 position in a Fixed length record but that did not help.

How can I insert a CRLF at the end of each record?

Please give your suggestions.

Thanks

Dhandapani,

I believe you are using IS6.x WmFlatFile Adapter.

your requirement indicates that you need a flatfile string with Delimiter(CRLF) as well fixedlength.

So in the FlatFileSchema editor use the RecordParser (Delimiter) option and select Record Character either (newline or carriagereturnlinefeed) optionlist.And keep the fixedlength fields as it is.

Finally test using the pub.flatFile:convertToString service you will see the results as expected CRLF for each record and fixedlenght data (550)

HTH,

Thank you,

Your solution works well.

Seems we have to use both options to create a single flatfile(fixedlength and Delimiter) in the record parser.