ebxml CPA with multiple CollaborationRole

Hi,

I am using the ebxml package (version 7.1 - Fix 3) on IS 7.1.2.

The “sendUsingTPA” service does not have an input for me to specify the service name, it only allows me to pass in the action in the TPA. Since I have mutiple CollaborationRoles defined in the CPA each having 1 service and each service having 1 or more actions, how should I use the “sendUsingTPA service” so that it can resolve the action for services defined in the CollaborationRoles other than the first one?

CPA with Multiple CollaborationRole:

tns:CollaborationRole
<tns:ProcessSpecification … />
<tns:Role tns:name=“ServiceProvider” xlink:href=“http://tobespecified” xlink:type=“simple”/>
tns:ServiceBinding
<tns:Service tns:type=“string”>OrderService</tns:Service>
tns:CanSend
<tns:ThisPartyActionBindingtns:action=“RequestOrder


</tns:CollaborationRole>

tns:CollaborationRole
<tns:ProcessSpecification …/>
<tns:Role tns:name=“CommunicationsProvider” xlink:href=“http://tobespecified” xlink:type=“simple”/>
tns:ServiceBinding
<tns:Service tns:type=“string”>TroubleReportService</tns:Service>
tns:CanSend
<tns:ThisPartyActionBinding tns:action=“AutoNotification” …>


</tns:CollaborationRole>

I can only send ebxml messages using the “sendUsingTPA” service for actions in the “OrderService” service. When I try to use the actions in the “TroubleReportService” service the “sendUsingTPA” service gives a error stating it cannot find the action.

As per ebxml specification 2.0 a TPA can have 1 or more CollaborationRole. So the CPA is correct.

Any help with this will be really appriciated.

Regards,
Gaurav.

Just thought I will provide a quick update. wM is working on a fix for this issue.

gaurav

I am struggling with CPA’s from past three weeks. I am upgrading webmethods from 6.5 to 8.0 Sp1. In our environment we never used TPA’s. Earlier we were using older versions. With ebxml 7.1 package I am forced to use TPA’s (CPA) correct me if I am wrong

Is there any generic CPA with unknown sender and unknown receiver. Can you share one sample CPA so that I can see how I can use it to implement TPA’s our environment.

Thanks

Hi,

I am trying to implement ebxml TPA’s with CPA’s in WM 7.1 but have been unsuccessful. I tried this using createTPA service by populating the inputs for cpa_2 doc type. I have also tried using the importCPA service with cpa XML string input. but neither method worked for me and getting the NullPointerException when I tried to send message using sendUsingTPA service. I could see the TPA created in TPA’s list though. i am thinking the CPA I am using is flawed with missing inputs. Can someone please share any insights of using the CPA’s to create TPA or if a sample CPA is provided would be greatly appreciated.

Thanks

hi,

I was successful building generic CPA’s for ebxml 1.0.
I am trying to implement ebxml 2.0. and I too got null pointer exception.
did you able to resolve the issue. Can you please share you CPA by export service.
I am not sure what are the missing fields in CPA.

Please,
Kishore.