Does 8.2 supports R12 Oracle

Hi All,

Oracle 11i to R12 upgrade is in progress, so we are checking what and all changes to be done in webM 8.2

For the same, created a jdbc connection with R12 instance and is connected, but while create/modify the existing adapter services is not allowing.

we try to change the existing schema to newschema where all tables present but it’s not allowing.

exception : [ART.114.243] Adapter Runtime (Metadata): Failed to run resourceDomainLookupValues service. Details provided in error log.
on procedureSignature.colIndexes [Ljava.lang.String;@fbed1b

java.lang.Exception: Adapter values are not available.

so, recreated a new adapter service, this time it’s not showing all the table columns.

Please help do we need to do any set up in configuration .

For webMethods itself Oracle 12c is not yet supported (up to 9.6).
See System Requirements documentation.

Make sure that you have installed the latest SCG 8.2 DataDirect 4.2 Fix.

For JDBC-Adapter you should make sure that you use the correct driver jar.

For wM 8.2 this should be the ojdbc6.jar from Oracle 12c.


Thanks for the reply !

let me try out the options which you suggested


SCG 8.2 DataDirect 5.0 Fix2 is even better

I know that oracle 12c is not supported until 9.6, but can we write a java service to connect to the oracle 12c database in webMethods 8.2 or is there any better way?
I tried to write simple java service to connect, but I got socket exception. I placed ojdbc jar file in the Package\code\jars folder.

Hi Raja,

please make sure you have the latest Fix for JDBC-Adapte applied (JDBC_6.5_Fix51 for wM 8.2).

Additionally you should place ojdbc6.jar from (can be downloaded from OTN) under WmJDBCAdapter/code/jars.
Reload the Package afterwards.

JDBC-Adapter should be working normal, except that you might not be able to use latest features of Oracle 12c.


Are you sure? What error do you get while enabling the jdbc connection?

Raja – I guess, we can write java service for your requirement, can you share your code, also full error stack trace.


There was a typo in host and when I corrected that I got this below error when tried to enable adapter connection.

[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource PNGJDBC:PeoplesoftFINDEVConn.
[ART.118.5063] Adapter Runtime (Connection): Unable to start connection PNGJDBC:PeoplesoftFINDEVConn: after 1 attempt(s).
[ADA.1.204] Cannot connect to the database with DataSource class “oracle.jdbc.pool.OracleDataSource”.
ORA-28040: No matching authentication protocol

I get same error with Java Service too, but I prefer to use webMethods adapter service if I can get this connection enabled.

I tried with eclipse IDE to connect to the database and it successfully connected.

I have placed ojdbc6.jar file in WmJDBCAdapter/code/jars and \IntegrationServer\lib\jars and installed latest JDBC 6.5 fix 51. I still get same error.

Do I need to install SCG 8.2 DataDirect 4.2 Fix1?


Raja – Yes, you can install and give a try.


Hi Raja,

Installing the DataDirect-Fix will not help with the JDBC-Adapter issue.

Did you specify “driverType=thin” for the “Other Properties” field?

Additionally check all fields of the Connection for any leading or trailing blanks.


Try with ojdbc7.jar


Hi ,

using the ojdbc7.jar in wM 8.2 will only work when the Java 1.7 update has been applied.

wm 8.2 is running on Java 1.6 by default for which ojdbc6.jar is best fitting. There is an ojdbc6.jar for Oracle 12c available.


I think ojdbc6.jar has all the required drivers to connect to Oracle 12c.

I found a KB # 1766738 article on empower about this topic and they say JDBC 6.5 does not support Oracle 12c if the adapter is used with IS 8.2, but it does support if JDBC 6.5 is installed on IS 9.0.1 and higher.

One should also note this point:

There is also a newer JDBC Adapter 9.0, and it requires a newer IS, v9.0 or higher. The 9.0 JDBC Adapter does support Oracle 12C.


I have installed oracle 12c on our test server and was able to connect to it using IS 8.2 and JDBC 6.5. I have placed ojdbc6.jar in \IntegrationServer\lib\jars and in WmJDBCAdapter\code\jars folders.

Also, added line “SQLNET.ALLOWED_LOGON_VERSION=8” to this file oraclehome\network\admin\sqlnet.ora

After making above changes it worked :smiley:

Good suggested setting in sqlnet.ora file with the jar fixed the issue. Thanks for sharing the results and closing this topic.


Jar-File is only required under WmJDBCAdapter\code\jars as long as WmJDBCAdapter is the only package using it.