Disable SFTP

I am using webmethods 10 and I’m trying to turn off SFTP. Every couple of minutes I get an email and an error saying:

2021-09-22 13:36:00 CDT [ISP.0090.0003I] SFTP Session: UNKNOWN – SFTP ERROR – Unable to open a session with server: [server] — Error message is : java.net.UnknownHostException: [server], Error
r.ServiceException: Unable to open a session with server: [server] — Error message is : java.net.UnknownHostException: [server]

We don’t need the webmethods to have this feature enabled, but I’m not sure how to turn it off. Can anyone provide some guidance?

Things to check

  1. The scheduler under Server->Scheduler for any repeating scheduled tasks ,
  2. It is possible that the SFTP configuration under Setings-> SFTP is incorrect.
  3. The service email has been configured in the Settings->Resources ->Email Notification to send out emails on service errors that is why you are seeing the emails every few minutes.
  4. Additionally checking the error logs /server logs could give you more hints .

-NP

1 Like

Hi Mark,

just wondering why there is an SFTP server configured when you do not require the connection?

In wM 9.5 and wM 9.12 there is no SFTP configured by default.

Regards,
Holger

I would think this was a migrated instance from 9.x to 10.x , that would explain the scheduled task and the migrated SFTP configuration, but if its not a migrated instance, then I do not have answers on how SFTP configuration can appear by itself :slight_smile: , would wait for more information.

It is reaching out because a service in a package is trying to get to an SFTP server. The issue is, I not all environments need the SFTP server. As a workaround, I was able to stop the service from executing, using an ACL. I created a Nobody group, added all other groups into deny, used the package manager > browse folders to find the service file that was executing the SFTP request and assigned nobody to the execute column. That being said, it throws a small access denied message into the log.

The next question is, can I disable a service without disabling the entire package? There are other services in the package that are necessary. I did find flow.xml and, but I’m not quite sure what that does.

Can you please elaborate what you mean by this? A service can execute if there is an explicit call to execute it or if there is a scheduled task to run it. Is this service being called by a third party ?

Also indicates to that it is being called periodically or multiple times.

-NP

1 Like

There isn’t a way to disable the service itself, but you can disable the steps inside the service (although this isn’t recommended, especially on higher environments).

flow.xml is the XML representation of your flow service in the back. Again, it’s not recommended (and not supported) to edit this directly for any reason, unless implicitly edited via Designer (i.e., by editing the flow service).

NP has a good question above, on the trigger element that’s calling this service.
Check if service is scheduled as a job; if not, then do a dependency check on this service (right-click the service on Designer and select Find Dependents) to see what other services are invoking this SFTP service - this will narrow your pool down. Then, check if any of those “parent” services are being invoked and you will find the culprit.

KM

2 Likes

Hi Mark,

when not all environments require this feature you should consider to split of this service into a separate package which will not be deployed to these environments which do not need access to the SFTP server.

Can you elaborate a bit more on the use case for this SFTP scenario?

Another idea (when separating this service from the others in this package is not an option) is to define a global enviromment variable which indicates if the SFTP connection is needed or not and then use the value of this variable in your service for a BRANCH condition to decide to invoke the SFTP part or to skip it.

Regards,
Holger

2 Likes