Disable Coversation Management in wM61

We are currently using the C1Onramp Adapter to exchange documents with a MarketSite using Trading Networks. According to the wM documentation for OnRamp we need to call the service wm.tn.cm:disableDocument.

This service exists in 4.6, but I cannot find it in 6.1. Does anyone know if it does exist or if there is a replacement??




Starting from IS6.0 the webMethods documentation says in the Wm_TNProgrammersRef.pdf for TN Conversation Management Services we have to refer the WmPRT package services.

Documentation Says:

The conversation management services have been removed from Trading Networks. Equivalent functionality can be
found in the process run time facility of the Integration Server. See the services in the pub.prt folder in the WmPRT
package. These services are documented in the webMethods Integration Server Built-In Services Reference Guide in
the pub.prt folder.



Thanks. In the PRT package there doesn’t seem to be a corresponding service to the disableDocument. After doing some more reading in the Trading Networks Users Guide it suggests all documents with conversation ID will be passed to the Process Runtime unless you set a variable called prtIgnoreDoucment to true in the in the pipeline.

This is my next step.

yes, you are on the right track,let us know the result after test.


So we added prtIgnoreDocument and set the value to true in the service in wm.marketconnect.tn.handler:routeEnvelope. All seems to be working fine now.

Thanks for your help!


Thanks for your update.Glad it worked.

I am using C1 on Ramp as well on IS 7.1.2
and applied the fix 39 did use this functionality adding the prtIgnoreDocument to true.
I tested the wm.marketconnect.tn.handler:routeEnvelope and I do have the value in the pipeline to true before the tn.routeXML is called.

Nevertheless, Trading Network stills try to use prt and I get the following error:

wm.marketconnect.tn.handler:routeEnvelope com.wm.lang.flow.FlowException: [ISC.0049.9010] Service ‘wm.tn.route:routeBizdoc’ invoking unknown service ‘pub.prt.tn:handleBizDoc’ at ‘$default’. The service may have been renamed, moved or disabled.

That should have been fixed with the fix39…

Do you have any idea, is there any fix I need to apply to TN?

Thanks in advance