Directory Read Permission Issue

Hi,

We are facing an issue while trying to access a unix directory and files in that directory via webMethods Integration Server.
The permission of unix Directory “Monitoring” is set as owner=root and group= “master”.
webMethods server is installed as user webmethqa in unix server and this user is part of “master” group.
When we connect to machine via putty with user “webmethqa” and try to access directory “Monitoring” , then we can access it and see the files.
But , when we are trying to list files via Integration server, its not working.
We are getting following error:
Null pointer exception and file doesn’t exist.

Not able to understand when “webmethqa” user is able to access files then why not IS which is installed with “webmethqa” user.

WebMethods Server version: 7.1.2
Fix Level: IS_7.1.2_Core_Fix45

Please help me with this issue.

Thanks,
Amit

What is the service used to list file. Can you share the complete error.

Also check mounting.

Hi Mahesh,

I am using pub.file:getFile service to pick the file as bytes.

I am getting error as :
//b00/inbound/InterfaceName/Monitoring/abc.xml does not exist

Could you please let me know what I should check in mounting as I am able to view this file via putty for same user with which webMethods is installed.

Thanks,
Amit

From the error its looks to me that the specified path is not correct. Can you check and confirm it again.

Since you are in wM 7 there is no config file for getFile service where this is the not the case in wM 8 and above.

Amit- Make sure there are no links on the FS, also files exist on the required directory.

THanks,

Amit- Make sure there are no links on the FS, also files exist on the required directory.

THanks,

Hi,

I have checked and can see path is correct.
Also, file is also available in that location.

Seems like more of user access issue as the directory in which file is present is having owner as root.

Thanks,
Amit

Is this file in local or network disk?

Hi Xiaowei ,

It is local disk on unix solaris.

Thanks,
Amit

Then why it starts with two slash //?

I have tried with both single slash / and double slash // but none of them is working.
Was going through other forums where putting double slash has resolved issue for other people.

Thanks,
Amit

One or two slash depends on where the file is, it should have a certain answer for that, no need to try.

In my opinion, the path starts with two slash is used to access to remote directory in network, and the service pub.file:getFile could be used only for local, so you should always pass the path starts with one slash to this service.

So the question is, is that really a local file? Because there is a folder named b00 under root really seems weird.
Could you run this command successfully from shell?

cat /b00/inbound/InterfaceName/Monitoring/abc.xml

Hi All,

Just to update this issue has been resolved now.

Solution:

  1. Changed the permissions to 770 for folder Monitoring.
  2. Rebooted the Unix machine on which webMethods server is installed
  3. Restarted webMethods IS
  4. Tried to access file in directory and it worked.

Thanks everyone for your help.
Much appreciated.

Hoping this solution helps someone in future.

Thanks,
Amit

Thanks for your time and information.