designer install error?

Get this after designer 7.2 fresh install.

!SESSION 2009-08-05 10:25:34.224 -----------------------------------------------
eclipse.buildId=I20080617-2000
java.version=1.5.0_15
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments: -Dderby.storage.pageSize=400000 -product com.webmethods.product.designer.ide
Command-line arguments: -os win32 -ws win32 -arch x86 -clean -Dderby.storage.pageSize=400000 -product com.webmethods.product.designer.ide

!ENTRY org.eclipse.equinox.app 0 0 2009-08-05 10:25:37.037
!MESSAGE Product com.webmethods.product.designer.ide could not be found.

!ENTRY org.eclipse.equinox.p2.director 2 0 2009-08-05 10:25:47.287
!MESSAGE Problems resolving provisioning plan.
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2009-08-05 10:25:47.287
!MESSAGE Unable to satisfy dependency from org.eclipse.wst.web_ui.feature.feature.group 3.0.1.v200807220139-7R0ELZE8Ks-y8HYiQrw5ftEC3UBF to requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.wst.web_userdoc.feature.feature.group/[3.0.0.v200805040310-21CE8s733I3D4C56AA,3.0.0.v200805040310-21CE8s733I3D4C56AA].
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2009-08-05 10:25:47.287
!MESSAGE Unable to satisfy dependency from org.eclipse.pde.feature.group 3.4.0.v20080603-7T7U-E_EkMNrNKb39WcMC to requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.pde.doc.user/[3.3.0.v20080611-1530,3.3.0.v20080611-1530].
!SUBENTRY 1 org.eclipse.equinox.p2.director 2 0 2009-08-05 10:25:47.287
!MESSAGE Unable to satisfy dependency from org.eclipse.jdt.feature.group 3.4.0.v20080603-2000-7o7tEAXEFpPqqoXxgaBhhhq to requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.jdt.doc.user/[3.4.0.v20080612-1340,3.4.0.v20080612-1340].

!ENTRY org.eclipse.osgi 4 0 2009-08-05 10:25:53.881
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: No application id has been found.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:236)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:382)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
at org.eclipse.equinox.launcher.Main.main(Main.java:1212)

!ENTRY org.eclipse.osgi 2 0 2009-08-05 10:25:53.881

Any ideas? I get this when I try to launch the designer. Thanks

Something has been installed badly in the Designer72\eclipse\configuration\org.eclipse.equinox.simpleconfigurator\bundles.info

Taking a good version from different install seems to have fixed it