designer 8

Not sure if this is the right place to ask, but I will try anyway.

Where can I get the designer 8 for webmethods 8?

Thanks in advance

I actually downloaded the designer.zip. Now what do I do? My understanding is that it is an eclipse version

It is correct that Designer is an Eclipse based client, but customized by SAG.

But a better way is to download the SoftwareAG-Installer from Empower/SoftwareDownloadCenter and use this one to download/install the necessary components through this Installer.

Additionally you should download the newest Fixes for Designer part with the UpdateManager (will be installed together with designer when selected) and apply them to designer.

If you have only the zip available (I am not quite sure what it really contains), unpack it on your PC and check for
eclipse\v36\eclipse.exe. execute it and check for result.

HTH,
Holger

thanks, but what do I do now with the zip file? how do I launch this particular eclipse?

thanks. but there is no eclipse folder after unpacking.

Hi,

If you have the webMethods 8 installer, license and image file, you can install the designer with other components (selecting option) during your installation process. After the successful installation you can launch designer from SAG folder.

Can you let me know from where did you download designer.zip file? Have you installed webMethods on your computer? (Windows/Linux)?

hello,

Thanks.

Here is the thing, we install and run webmethods on unix server, and I believe the eclipse/designer is installed and running on my windows pc.

I suppose I could get the windows license and image and then just install the designer piece, but that seems to a a waste of time. Is there anyway to just get the eclipse/designer for windows?

appreciated.

Derek

Yes, there is a way to get Designer 9.5 for Windows 64 bit. If you would like to download Designer 9.5, go to the SAG TECHcommunity home page at http://techcommunity.softwareag.com/web/guest and you will observe a link to download a free trial of webMethods. The free download includes Designer 9.5. Designer 9.5 includes an updated version of Eclipse, version 4.3. Designer 9.x is backwards compatible with IS 8.2. This information we received from the SAG team. I believe it is probably also backwards compatible with most any 8.x version of IS. Just be sure to abide by all the software license agreements especially the SAG agreements – my disclaimer.

thanks to all.

problem solved, turns out I just need to run the installer with the zip file.

Again, much appreciated for all your help, this community is great.

:smiley:

Hi,

Now I have a new problem. I used this Designer (8), and pointed to an existing Webmetods 7 (since designer is backward compatible). I have a java service which uses external jar files, and these jar files are sitting at the correct folder for the package on the server where Webmethods is installed and running, and java service compiles and runs fine from using Developer 7. However, if I open the java service in designer 8, it complains about missing jar files (the external jar files).

Do I need to copy these external jar files to my pc? and if so, how do I install them in the designer?

Thanks.

Derek

Note: this is for Designer 8.2.

You have a couple of options:

  1. You can ignore the errors Designer is reporting. When you save your Java service in Designer, it will compile it on the server, using the jars loaded on the server, just like Developer does. As long as you don’t mind the error highlights and don’t need to use the Designer’s debugger, you’re fine.

  2. You can add the JAR files to your local installation. First, copy the JAR files to your local system (it doesn’t matter where). In Designer, switch to the Java perspective and find the package with your Java service in the list. Open up the package and right-click on the Referenced Libraries. In the popup menu, pick Build Path->Configure Build Path. In the window that opens, click the “Add External JARS…” button and select the JAR files you want to add. Once that is done you should no longer see the bogus errors.

Many thanks.

I was a bit busy with some other stuff so have not tried it yet.

One question, if I add the jar files to my local installation, when I save the Java service in Designer, it will still compile it on the server, right?

Regards.

More problem.

So I have successfully installed designer 8. Now to designer 9.5

I got the image and installed, but after start the eclipse, there is no “Service Development” in the Perspective. I also noticed that at the eclipse start up, version 8 would say “Software AG” and “Designer 8” on the start up screen, the version 9 is just a plain regular eclipse 4.3.

If I look at the installation log file, it actually says Service development is installed.

So I downloaded the Free Trial version of webmethods, and installed just the Designer, and I got exactly the same result as before, no Service development perspective.

Did I do something wrong here?

Regards.

Derek

@ Derek,

I am pretty sure that we have Service Development Perspective in webMethods free trial (I have installed it on Windows) and I using it regularly.

Not sure whether there is a conflict between designer 8 and 9 (just a guess) :slight_smile:

Can you re-try downloading/installing webMethods free trial again.

Hello M@he$h,

I re-downloaded the trial version, and installed on a windows pc that never had version 8 designer before, but to no avail, still do not have the Service Development Perspective.

Is there something I need to do before I bring up the Eclipse or after?

Regards.

These are the steps I did
1> Downloaded webMethods trail image and installer and copied both in a folder
2> Received the license key to my gmail id and copied that to the above folder
3> Started the installer and provided the image, selected the components (IS, designer and others) and license key
4> After the installation (success) I started the IS from Windows>All Programs>SoftwareAG>
5> Waited for the IS to come up and opened the IS page
6> Launched Designer from Windows>All Programs>SoftwareAG>Tools
7> Designer started and prompted for work-space (selected the default one)
8> Open the Designer and by default it was in “Service Development Perspective”

Try this out from step 8 go to Window>Open Perspective>Other. In Open Perspective dialog box, select Service Development and click OK

Let me know your results. Meanwhile can you tel me your JDK version?

M@he$h,

Since our IS 9 and MWS 9 are installed running on a unix server, and I am only after the designer 9, so I only selected the Designer to be installed on my pc.

The thing is on the installed eclipse, Window>Open Perspective>Other. there is no Service Development in the list.

I will try to install all of the components from the trial version on my pc and then see.

BTW, the installer is an exe file so I am not sure if it is even a java app. The installed eclipse, it is version 4.3, and java version is 1.7

Regards.

OK… Give it a try :slight_smile:

Lets see what others comment. Let me know your results.

well, I re installed (selected everything that came with the image), still no good.

Will create a ticket with WebMethods support and see what happens next.

Thanks.