Deployment ISSUE

I want to deploy a package I created on test server (and after prod server).
After creating my project, my build and my map (I have no problem of reference in map step and define step), I have a problem in deployment step :

[ISS.0086.9143] Package file ‘’ does not exist in Inbound directory

I suspect a problem of size. Because My package have 12 Mo as size.

Any idea how to fix it ?


Hi Vital,

which wM version?
Any Fixes for Deployer applied?

Was the WmDeployerResource package installed on target server?
(Needs to match the Deployer Fix level, so it needs to be updated after applying Fixes to Deployer)

Was the Deployment Candidate simulation successful?
Any issue while taking the Checkpoint?

Any messages in the server.logs of the two IntegrationServers?


Hi Hölger,
Thanks to reply

which wM version?
Any Fixes for Deployer applied?
Fixes are upto date in the two Integration servers

Was the WmDeployerResource package installed on target server?
(Needs to match the Deployer Fix level, so it needs to be updated after applying Fixes to Deployer)

Was the Deployment Candidate simulation successful?
Any issue while taking the Checkpoint?
Any messages in the server.logs of the two IntegrationServers?
Same message in the source server : Package file ‘’ does not exist in Inbound directory

I have to say that for other package, I haven’t the issue

I suspect a problem of size. Because My package have 12 Mo as size. → I don’t think so that will be the issue.

Are you the deploying it as a whole package or as an patch to the target?


Thanks for your reply.
I déployer it as a whole package. But this one depends on other packages. But I deploy the others before. So I dont think the problem is a question of dependency. Besides if it was the case, the problem would beaucoup a problem in map step instead of deploy step and I would understand the error message


Can you check you have that package on the target server’s replicate/inbound directory?

If you do, does it work if you delete it and run the deployer project again?

If not, have you tried deploying the package manually (publish on the source, and then copy from replicate/outbound to the target’s replicate/inbound)?

If this works, will it work if you now run the deployer project again (crashing the installation you just made)?

Best regards,

Thanks Gerardo,
I have nothing in inbound subfolder in replicate folder (of WMDeployer package).
I don’t know how to deploy manually.
Usually I do that for production server.
I copy and past my build file and my deployment file from the development server to the test server and after importing map and build file, I create a deployment step in test server (with imported build and map file) and I deploy in production server.

But I don’t know how to deploy manually without using the development step.

Hi Vital,

can you please explain your environments?
Deployer installed on each instance?
What do you refer to as the deployment file?

We usually export, transport and import only the build files.
Maps will be created on the target servers during our deployment process.
Preparing, exporting and importing maps is only of interest when the source server (where they are created) has a Remote Server definition of the target instance or a direct connection defintion for Process Models available.
Otherwise the dependency checking will fail and will take quite a long time before timing out.
Therefore we have separated all nodes which might require variable substitution to a separate package which is created on the appropriate targets manually.


Ok stop me if I am wrong somewhere :

I have a development server, test server and production server.

If I want to deploy some package from development to test, I use the deployer.
I create a deployment project where in the define step I refer to my package.
I create a build (and I export it to have it on replacate/outbound folder of my development server).
I create a map where I refer to my test as target server (the alias on the development is the same as on the test server but the ip is not same : in dev it is the test server, it test it is the production server. So I can export it to have it on the replicate/outbound folder).
Then I create a deploy (refer to my build and map I created) and deploy on production.

When I want to deploy in production I copy and past my file I created during exportation (of build and map step) from replicate/outbound folder of development server to replicate/inbound folder of test server.
Then I import build and map file in the deployer of the test server. That create a project in the deployer. Then I create a deploy (refer to the build and map I imported) and deploy in production (that’s work because the alias of the target is the same in test than in dev).

But for my project, I try to deploy my package and that dosen’t work in deploy step.

Hi Vital,

did you check, that the remote server definition on each deployer is pointing to the correct instance?

Please note that there are two different replicate folders on each instance, both having inbound and outbound subdirectory.
One is located under IntegrationServer/instances/default/replicate and one is located under IntegrationServer/instances/default/packages/WmDeployer/replicate.
The Builds and Maps from Deployer are placed in the second location, but during deployment Deployer extracts the package from the build to the first one and activates it from there into the namespace of IntegrationServer.
Therefore on your targets there should be files in this inbound directory or the archive directory beside it.

Usually we are creating the maps directly on the target servers as the source servers do not have access to the target servers due to firewall restrictions. Only DEV and TST have the same Deployer hosted on TST, as these two reside in the same network segment, but QA and PROD are each located in different network segments and all these segments have no access to each other.


Hi Holger,
I think it is the copy in the first subfolder wich failed.

Besides I notice that the package is however copied in integrationServer/instances/default/packages even if the deploy failed.
And after in package management, I can Installe Inbound released and that works.
After, if I deploy again (new version) the package I haven’t the problem again.
I suspect te system copy the file in the first directory you mentionned but another thread make an action as Install inbound released from this folder. But the copy is not finished and the system said the package doesn’t exist.

So my problem is solved by clinking in Install Inbound releases in package → Management. But it would be good to know how to fox it in the deployment.


A side note: I usually test small deployments with the old tradicional way of placing the package’s zip file in the IS instance’s /replicate/inbound. That is also where WmDeployer places the package files before installing them.

From what you described so far, maybe you are having a timeout issue in WmDeployer.

Please check WmDeployer Solution->Settings->Deployer Service Timeout.

In my case I had to set it at 150 000 ms.

Good luck.


you should consider splitting the package into smaller ones.

Another option might be to go the properties of the package after it has been selected in the define step and mark “*.bak” files to be excluded from the package during build. This will help to save some space.

Can you explain why this package has grown to such a big size?