deploying to clusterd environment


We are using Deployer 6.5.1 and we are trying to deploy the code to testing environment where the IS is clustered into 2 servers. I followed the deployer guide and deployed the package to the primary node of the cluster and according to it the primary will replicate the package to the other server in the cluster, but it is not happening in our case. We can see the package only in primary server. I have added the two clustered servers’s alias names in the extended settings only in the server from which iam deploying. do i need to deploy to both the servers in the cluster?? and if its enough if i do to primary only then what are the other things i need to consider??

We have followed the Configuring Cluster Synchronization for Deployer section in the Deployer User’s Guide 6.5.1 pg no. 16 and 17

Hi Vinny!

Are the 2 integration servers that you said in cluster are in ACTIVE - ACTIVE mode or ACTIVE -PASSIVE mode,if your IS’s in cluster are in ACTIVE - ACTIVE mode then the packages that you are deploying will be replicated on both IS’s automatically when you deploy.
If your IS’s are in ACTIVE - PASSIVE mode then when you deploy the packages it will be taken by the IS which is in active mode other IS becomes active when the first one fails due to heavy load,so check the modes of the 2 IS’s which are in cluster.



I am also facing the below mentioned problem. Do i need to do some settings ??.. My cluster environment is in active-active only.

It is throwing an error like is offline. It looks like it something it is refering which is not available.

Could any one suggest, wht to do for this issues.

Warm Regards,
Gopinath K.M

Side note: IS clustering has no notion of active-passive. IS clustering only supports active-active.

Active-passive clustering would be provided by the OS or third-party solution. wM Tech Support has indicated that an active-passive configuration of IS is not supported.


Resolution: while adding the server in the deployer, please give the same name as shown in the cluster . Goto the cluster and see the name what is tooks.

Delete the DeployerResourse package in both the server . Generate from the first from the install option available in the servers

Ex: blr12034. You should not give its IP or fully qualified name
Also ping the server in the servers list in the deployer.

Hope this should work. After doing some research i solved this issue like this only…

Have you defined alias for cluster servers in Remote Server ? How you are defining the cluster alias property in server.cnf ?

Two cluster servers alias names should be separated by comma.

We are using deployer to deploy in cluster environments. We are only deploying it on one primany node and deployment automatically done on other server in cluster.

Have you set the “Cluster Support” to Automatic in General Deployment Defaults in settings?