Deployer cannot delete Broker document when doing Rollback .. ?!

I’m experiencing a problem in using Deployer … I tried deploying my project from Development Server to Production Server using Deployer package, and there were problems … Now when I tried doing a Rollback in Deployer to undo the changes made on the target server, none of the Broker documents from the target server are deleted because of errors such as this:

Could not delete the Broker Document Type named “wm::is::ARS::docTypes::ARSWrapperNew” due to an exception: Operation failed because permission is denied. This operation requires administrative permissions.

There are 20 or so such errors, each with a different document name mentioned …

Can someone tell me what might be causing this ? … To what do I assign privileges for this to happen, and how ?

Really need help here from someone …

The deployer at times cannot delete broker doucment types. To handle this you can do either of the two thigs

  1. Using MWS manually delete the broker doucments that you want to delete.
  2. Make the deployer user(s) as administrators so that it can delete the doctypes.

Also ensure that the doucments which you want to delete are not shared by more than one service which is running, as that can cause issues.