Deployed microservice is not able to find the path

Product/components used and version/fix level are you on:

Cumulocity Production

Detailed explanation of the problem:

Hi, I am using cumulocity enterprise version. I have deployed one microservice which is working absolutely fine in local but i am getting 404 not found when testing in postman. I tried changing paths but still i am getting 404 for the path.
Below is my microservice configuration. I am not able to understand that why it is not able to find the path. I am not getting any error logs either

Hoping anyone would have an answer for this.

Best Regards,

Hi @Sam123 ,

could you please share where and how you get the 404 error, like what you do in Postman, how the API call looks like?


Hi Kai

The hidden url is the client url, and then the configuration of the microservice. There are other microservices also which are already deployed and working fine so there might be an issue with my code but as I already tested in local and it is working fine. So :-

  1. Is there any additional configuration we have to do in code make it work?
  2. Is the microservice name could be an issue? as i placed 2 “-” in it?

P.S: I am also passing 2 parameters but since it is not able to find the path only so that is not the issue, i already tried it by passing it multiple times in different ways.


Hi Samanyu, which port does your microservice run on? It has to be 80. Could you please check it in your code?

This error is coming from the microservice itself that no endpoint is defined on /data.
It is Java based microservice, right?
Please also share the code of your controller-class providing this endpoint.
There is probably a tiny mismatch only.

  1. Let’s see your code first :slight_smile:
  2. No that is fine!
  3. What kind of parameters? URL parameters or within the body?
1 Like

Hi Kai, It was a issue from code side only Just had to mention mention some annotations. It is working now thanks


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.