Error when upload application to Microservice

What product/components do you use and which version/fix level are you on?

I’m now using Microservice of Cumulocity IoT Platform.

Is your question related to the free trial, or to a production (customer) instance?

The tenant is: bulut-dik-2021 dot cumulocity dot com

What are you trying to achieve? Please describe it in detail.

I want to upload my application to Microservice. I have already created docker image file and manifest file, and package them to a zip file. I have also run the image file on docker and didn’t have any problems.

Do you get any error messages? Please provide a full error message screenshot and log file.

When I choose “unsubscribe” and go to the URL of my microservice, the homepage will show, but any link on the page is 404 by clicking on it. (I think it’s also something wrong)

When I choose “subscribe” and go to the URL of my microservice, there will be error message: “microservice/not found”

Have you installed all the latest fixes for the products and systems you are using?

Hi @yujia.gu,

  1. Are there any logs shown in the “Logs” tab of the microservice?
  2. What do you mean by “homepage will show”?
  3. Just to confirm: You uploaded the microservice directly to your tenant and have the microservice-hosting-feature enabled?

Regards Kai

Hi Kai,

  1. When this error occurs, there is nothing in ‘Logs’, it is empty.
  2. homepage means the first page of my application
  3. Yes, I’m sure about that. I have already uploaded the microservice and have the ID and path.

Regards Yujia

Hello,

Could it be something to do with the manifest file writing? The picture below is my manifest file ‘cumulocity.json’.
1668770779565

Best regards, Yujia

Hi Yujia,
could you elaborate on what your microservice is doing? I am a bit confused still about the “homepage”, so do you have a custom UI application which is connecting to the API of the microservice?
For a generic test you could also build and deploy the hello world microservice just to ensure there is no problem with your tenant setup:

Regards Kai

Hi Kai,
I use the microservice to establish a web application. I use flask to create the web application. I think the problem is about “cross origin”. Because when I run the web application in local or in the docker, there is no problem about my web application. But when I upload it to the IoT Platform, I receive an error code 405. I have tried to solve this problem, but it doesn’t work. You can see the picture, the header are changed when I upload it to microservice. And .css file can’t be visited. But there is no problem when I run the image file in the docker.

Best regards, Yujia