Deploy CAF application to My webMethods Server

Hi There,

I am a new in CAF. I created a sample portlet project, but when I tried to deploy it to My webMethods Server, it keeps asking me to provide the username/password. I am sure I provided the correct password. I tried the sysadmin, Administrator and my personal account with My webMethods Administrators, IS Administrators, IS Developer roles but no luck. Do you have any idea about this? Thanks in advance.


It’s been a while that I worked with MWS, but syadmin should indeed work.

The sysadmin account is actually the true “root” account of MWS. Whereas Administrator is more like a super-user for the admin functionality of webMethods components. Roughly(!) comparable to sys and system on Oracle databases (unless the latter has changed in recent years).

1 Like

Thank you Christoph for your reply. Did you see this issue before? And do you have any suggestions about what are the possible issues and what I should check on this? Thanks again!


No specific advice, since for me there is not enough detail in your description.

As a general approach what has helped me numerous times is to explain the problem to someone in great detail. In many cases, while doing so, I realized what the issue was.

If you are inclined to do this, you can of course take that approach with us in the forum here :-).

What might help, if you haven’t done it already, is to look into the log files of Designer/Eclipse and more importantly of MWS. That will at least give you a hint if you even reached MWS on a network level, or need to look elsewhere.


Hi Christoph,

I can deploy my CAF to MWS successfully after I added the Monitoring port of the MWS servers in Designer. Thanks a lot for your feedback and suggestions.


1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.