Deploy AccountExample.ear under Sun Java 2 SDK Enterprise Ed

Problem Environment: Sun J2EE 1.3, Tamino 4119, Win2K proffesional.

I am trying to deploy the AccountExample.ear into the Sun J2EE app server. The deployment goes ok but there is a warning if I run j2ee with -verbose:

Warning: Reference reference java:comp/env/eis/accountDS is using a JNDI name that is not bound: MyTaminoConnector

The result is that if I run the example client application I get lots of CORBA and transaction related exceptions which basically boil down to the root cause : a javax.naming.NameNotFoundException: MyTaminoConnector not found.

How do I correct the error? Is there something I missed?

Stuart Fyffe-Collins
Software AG (UK) Ltd.

… got a bit further. I changed the Reference JNDI name to MyTaminoLocalTxConnector and the deployment at least works. But when I run the client application, I get the following with the exception at the end. Any ideas?

>> java ejb.session.stateful.TransferClient
ATTENTION: Usage: TransferClient
using default JNDI-NAME
create Session bean

getBalance for 333-456-7890
333-456-7890 = 383.0

deposit 200 to 333-456-7890

getBalance for 333-456-7890
333-456-7890 = 583.0

withdraw 150 from 333-456-7890

getBalance for 333-456-7890
333-456-7890 = 433.0

getBalance for 111-456-7890
111-456-7890 = 111.0

transfer 77 from 333-456-7890 to 111-456-7890
test failed
java.rmi.RemoteException: CORBA BAD_OPERATION 0 No; nested exception is:
org.omg.CORBA.BAD_OPERATION: minor code: 0 completed: No
org.omg.CORBA.BAD_OPERATION: minor code: 0 completed: No
at java.lang.Class.newInstance0(Native Method)
at java.lang.Class.newInstance(
at org.omg.CORBA.portable.ObjectImpl._invoke(
at ejb.session.stateful._Transfer_Stub.transfer(Unknown Source)
at ejb.session.stateful.TransferClient.main(Unknown Source)
remove the bean

Solved the problem! I found a posting on the java forums at and mentions that this problem crops up if the interface name “conflicts” with a business method name. In the sample AccountExample.ear the Transfer interface has a transfer() method. So after unbundling it, changing the method name from transfer() to transferAmount() in the bean, remote interface, etc, then recompiling, repackaging and redeploying the sample works.

Best regards,

Stuart Fyffe-Collins
Software AG (UK) Ltd.

You have to add a connection factory:
%SUN_HOME%\bin\j2eeadmin -addConnectorFactory MyTaminoConnector TaminoJCA_localTx.rar

Josef Haiduk

thanks Josef, that did the trick!

Cheers, Stuart