Degree sign Issue

Hi All,
We have an issue. The application is providing a text with Degree symbol and the partner expects same in the EDI document . But the Transaltor mapping as .

Source : SOLIDS CONTENT @ 20 °C / 68 °F

Target: SOLIDS CONTENT @ 20 °C / 68 °F

What I am understanding is : The degree sign (which is extended ascii code “167” ) is not supported by webMethods EDI since it is out of the range of basic ASCII (either 0-127 or 1-128, depending on if it is zero-based index). I think, because of this, we are seeing garbage characters in EDI.

Anybody got this issue before?

WebMethods Release notes says :
“ As required by the EDI standards supported by the webMethods EDI Module version 6.5.2, ASCII or a subset of ASCII character set is supported. Extended character sets may be used in X12 and UN/EDIFACT if communicating parties agree. Those extended character sets have not been specifically tested but should work reliably”

Yes that is what happening and so you may need to replace that hex chars totally from the output and out of box there is no fix provided by SAG EDI module to deal those spl garbage chars as far I know.

HTH,
RMG

which Transaltor are you referring to?
The key here is the encoding that is used in the original system, in WM, and in your Translator.
If you use UTF-8 encoding in all systems, there shouldn’t be any issue.

I saw this issue with UTF-8 also…How do you set this in wM EDI side encoding normally?

If you consistently use UTF-8, and display it as UTF-8, it will work. There is no config in WM EDI, if you use AS2, the encoding is defined in the Content type setting for the content part.

if you see: °F
that means you are displaying a UTF-8 encoded string as ISO-8859-1 encoding.

Reason:
the Hex for degree sign in UTF-8 is: C2 B0
in ISO-8859-1: B0
and in ISO-8859-1, C2 is Â

BTW, basic ASCII doesn’t support degree sign. If you have a degree sign, you are most likely using UTF-8 or ISO-8859-1 encoding.

ok good notes: