Datapoints available but no device connected

Dear all,

I have got a problem, that I still have some data points available in the widget list, but the device is not existing anymore.

What I mean in detail ist the following:
I still can see some data points in the list of data points if I got into the details of a widget, i.e. a data point graph.
But that data point “Flow rate average old” belongs to a device, which is no longer connected to Cumulocity.
So I tried to erase that data point with the “three dots menu”, but there is no option available as you can see in picture 1:

But what I get at this point is an error like you see in the 2. picture:

image

Does anybody has an idea what to do?
How can I erase these old datapoints?

Thanks a lot!

Hi Oliver,

I’m currently trying to reproduce the behavior you have described, but couldn’t cause the error.

What version of Cumulocity do you run? What widget did you use? How did you create the dashboard, on group level or device level?

Normally, you should be able to remove data points from the list via the dots menu. In your case it didn’t work, because of some bug. I would forward this to support, but for this I need to able to reproduce the error.

Best regards
Christian

Hi Christian,

we are using the version 10.10.0.12 of the Cumulocity.
And I am using different standard widgets like the “datapointgraph” and “info” in the group level.

Yes I wonder why I could not find anything behind the three dot menu.
I know that it has worked bevor?!?

Thanks for your support!

Hi Oliver,

I have checked it again could verify that there seems to be an issue for data points for which the underlying device doesn’t exit anymore. I will follow up with support and R&D on this issue. Right now, the only solution would be to remove the data point description manually via the managed Object of the dashboard and its widget configuration.

Thanks for reporting this issue.

Best regards
Christian