Cumulocity IOT free trial error

What product/components do you use and which version/fix level?

Cumulocity IOT

Are you using a free trial or a product with a customer license?

Free trial

What are trying to achieve? Please describe in detail.

I am trying to set up a free trial account of cumulocity IOT as a part of a task provided by Snowflake Course. But I am continuously receiving an error message which says, ‘Some error has occurred. Please try again’. I have tried refreshing, setting up a different account using different email id. I also tried logging on/off and using a different browser. But the problem is still there.

Do you get any error messages? Please provide a full error message screenshot and log file.

Have you installed latest fixes for the products

I have the same issue.

Hi Sanket,

You are trying to set up a free trial of Cumulocity IoT, but in your screenshot I see webMethods.io Integration under your products. Are you trying to use both products? Did you have issues setting up webMethods.io Integration?