Creating IDOC template

I’m trying to run “createIDOCtemplate” service of the WmEDI adapter to get the template for PEXR2001 IDOC from the SAP server. The B2B server connection to the SAP server is fine.
When I run the service, it doesn’t fail yet I don’t get the template output. All I get is a variable $rfcname with value EDI_IDOC_SYNTAX_GET.
Any thoughts…!!!

Thanks for your help.

Why don’t you just download this template from SAP at http://ifr.sap.com/catalog/query.asp

Hi,

I faced the same problem for creating IDOC template using the same service.
I dont know what WmEDI Adapter version you are using and I assume it is 4.0.1.

If so then they have a bug and the best way to overcome this is to install WmEDI Adapter version 3.0 and run the same service and createIDOC templates and reinstall the WmEDI adapter 4.0.1 back.

Thanks
Chris

I’m having a similar problem. I’m trying use the createIDOCtemplate service but am getting the following error:

com.wm.app.b2b.server.ServiceException: com.sap.mw.jco.JCO$AbapException: (126) SYNTAX_NOT_FOUND: SYNTAX_NOT_FOUND

We are running IS 6.0.1 SP2, EDI 6.0.1, SAP 4.6 (but without SP5), SAP 31I. I’ve successfully run this service using SAP 4.6 SP5 and SAP 46C.

I double checked my input to make sure it was right (package existed, folder path was correct, dictionary existed). I wasn’t sure which IDOC version to use, but got the same error with all 3 listed.

In the details screen of the message, the last service invoked was pub.sap.client:invoke. The $rfcName in the pipeline is EDI_IDOC_SYNTAX_GET. I can test this RFC directly from the SAP Administrator browser screen, so I know the function exists and works.

I’m am going to request the installation of SP5 for the SAP adapter, but not sure if this will solve my problem. I checked and there are no SPs available for the EDI module. I did a quick search of the EDI fixes and didn’t see anything there either.

Anyone seen anything like this with older versions of SAP? Any ideas are welcome!