Creating CloudStream Provider

Hi Experts,

i had the following questions :

  1. is it possible to send a raw json request as an input to the CloudAdapterService ?

My cloudService has the following :

InputParsingType = application/json
outgoingparsingType = application/json

I have referenced the input to a documentType which has a string called “jsonMessageRequest” .

When creating the CloudAdapters, i can see the requestBody having the string called “jsonMessageRequest” [Which is right] .

When i pass a valid json request as below:

{“to”:“myemailid” , “emailBody”:{“body”:“This is a sample message”,“title”:“Sample Title”}} to the “jsonMessageRequest” string .

What i notice is that my JsonRequest is getting appended by the string “jsonMessageRequest”

So my request looks like this now

{“jsonMessageRequest”:{“to”:“myemailid” , “emailBody”:{“body”:“This is a sample message”,“title”:“Sample Title”}}}

How do i remove this string which is getting appended to the jsonRequest which i send?



If you are creating your own provider/connector, with the request and response, you can use the json data format. If you want to remove the jsonMessageRequest key, you should have the request as a document type, turn on exclude root for that and within it, you can have the fields to send to the backend. That way, your request will not have the top level entry. If you still face issues, you can open a service request.