Creating a canonical document makes the data null in the document

I am trying to create the canonical document but i am having problem…let me explain the system:

I have 2 source(Oracle And XML) --> 1 target (Oracle)

Lets say documents has following values:

Source Oracle Document has 3 values A,B,C
XML Source Document has 2 values D,E
Target Oracle has all 5 values: A,B,C,D,E.

In order to make the Canonical Document
I am assigning(map) the Activation_Id of Oracle -> Activation_Id of XML.

But when i do that it values of D & E becomes null in XML Source Document…

so it inserts a row in ATC_XREF table but when it tries to enter the row in Target Oracle, it fails… and works fine if i hardcode the values of D & E . how can i do this? any idea?

TIA,
Ashesh.

Have you tried setting the “Allow unset fields” option on the publish? This will help you identify if a value is not applicable or really null.

Peter

My guess is that when you assign the Oracle activation ID to the XML activation ID. Your XML object is being overwritten with the Oracle object. Have you tried using the createXReference to create a new canonical entry and using that id?