Could not open session to host 'localhost:5555&


I am getting the following error when tried to connect to the WM Developer for the first time. I tried Administrator/manage for username/password

Could not open session to host ‘localhost:5555’.

Then I ran server.bat and got the following error.

C:\Program Files\webMethods6\IntegrationServer\bin>server.bat
java.lang.NoClassDefFoundError: javax/crypto/f
at javax.crypto.Cipher.getInstance(Unknown Source)
at Sour
at Sourc
at java.lang.Class.newInstance0(Native Method)
at java.lang.Class.newInstance(
at Source)
at Source)

C:\Program Files\webMethods6\IntegrationServer\bin>

Can someone please help.



There were some issues with IBM JVMs that showed this error a few years ago. You should check with technical services to see if there are updates available for your configuration.

Hi Vinoda,

you need to have JVM installed in your machine and try running the server.bat file after deleting the LOCKFILE in the same directory.

try running in the cmd promt

server.bat port 5555 log -none debug -6.

you may ignore port 5555 if the above command fails.

Quick fix from Advantage problem announcement:

"To prevent the failure from occurring for Integration Server users we recommend moving to the Sun 1.4.2 JVM.

For Windows, Sun and HP users, this version of the JVM ships with Integration Server and should already be installed in the webMethods directory. In order to configure the Integration Server to use the Sun JVM, follow these instructions

  1. Navigate to the <webmethods_install_dir>\IntegrationServer\bin directory and open the server.bat (windows) or (Unix) file in a text editor.
  2. Edit the JAVA_DIR parameter and point it to the JRE shipped with webMethods, located in <webmethods_install_dir>\jvm\win142, then save and close the file."