Connection Error while running Database Component Configurator after installing webMethod

Error Description:

After successful installation of Webmethod and Microsoft SQL Server (in this case), the first step is to RUN Database Component Configurator for the TABLE creation of the required WM Components and Product.
Most often we get the below error details after executing the DB Configurator.

  • Executing action
  • Action : create
  • Database : SQL Server
  • Component(s) : storage
  • Component(s) version : latest
  • URL : jdbc:wm:sqlserver://localhost:1433;databaseName=master
  • User : sa

  • create Database Component: Storage STR

  • Versions
  • Version: sqlserver 30.0
  • Scripts create
  •   Script(1): C:\SoftwareAG98\common\db/scripts/mssql/storage/30/create/mss_str_c_ddl_database.sql
  •   Script(2): C:\SoftwareAG98\common\db/scripts/mssql/storage/30/create/mss_str_c_ddl_user.sql
  •   Script(3): C:\SoftwareAG98\common\db/scripts/mssql/storage/20/create/mss_str_c_sp_kill_process.sql

  • Database Connection error: [SoftwareAG][SQLServer JDBC Driver]Error establishing socket to host and port: localhost:1433. Reason: Connection refused: connect

Resolution :

Step 1 : Check if the connection URL specified in the DB Component Configurator is correct or not
Correct URL : jdbc:wm:sqlserver://:1433;databaseName=
Where <> and depends upon system to system

Step 2 : Open SQL Server Configuration Manager and check for each SQL Server Configurations whether the TCP/IP and Named Pipes are Enabled or not.
If Disable, then Enable it.

Step 3 : After completion of Step 2, open services.msc using RUN command(Window+R) and STOP & START the SQL Server (MSSQLSERVER) services , so that the STEP 2 changes gets reflected at the Service level.

For STEP 2 and STEP 3 , you can refer the attached screenshot.

After completing the above mentioned steps, EXECUTE the Database Component Configurator , which will now be success and all the required TABLES will be created.

Ankit Tibrewal


Thanks for your efforts in writing this. I really appreciate :slight_smile:

Thanks a lot Ankit, my db issue got resolved :slight_smile:

Perfect :slight_smile:

Thanks for highlighting.