Challenge in Encoding UNEDIFACT data in iso-8859-1 format

Dear Team,

I have a requirement to encode UNEDIFACT data in “iso-8859-1”(ANSI) format to handle the special characters.

Integration Server is considering UTF-8 as the default encoding format when the document is submitted to TN. I have tried the below approaches to change it, but no luck.

  1. Added “$contentEncoding” parameter with the value as ‘iso-8859-1’ in ‘TN_params’ for “tn.doc.xml:routeXML” step.

  2. Tried add the encoding parameter in “wm.b2b.edi.util:addICEnvelopeEDIFACT” , wm.b2b.edi:convertToString

  3. Tried to convert the EDI string to Node by giving encoding parameter and used “”. But the EDI document is not getting recognized at runtime. Hence i couldnt do the "tn:submit " step.

Could you suggest me a way if anyone come across the same problem.

iso-8859-1 is not the same as ANSI, it’s a western EU-specific encoding.

I guess you are trying to process received document, so it’s a decoding issue.

so the entry service is the key. How do you receive such documents? AS2? pls provide more detail.

Hello Tongwang,

I was trying to send Invoice96A UNEDIFACT data in encoded format . It was an outbound transaction!

However the issue is solved with different approach.

I tried to submit the encoded EDI string to TN as described earlier , but for some reason TN was not considering that parameter. Hence I set the encoding parameter in the SendEDIINT step(delivery step) which started working.