CATALL - report mode and structured mode


I have several libraries to be cataloged. A lot of them also have several Natural objects, and these objects are mixed – report mode and structured mode. If I use CATALL command, and the object has already existed, it works fine, however, if it is necessary to catalog the object, so, and error NAT0623 occurs if structured mode is set as default.

At this moment, I think I will have one option. The first step , I would have to catalog using report mode, and then, a new catalog process using structured mode.

As structure mode is the standard, so I only would consider the erros on the second step - cataloging using structure mode.

Does anyone know if this way is the only one, or is there a way to do it at once? If so, please, let me know.

tks, regards.

Sorry, no matter what I try, I can’t reproduce this, and it shouldn’t matter
if a GP exists or not, if the source is flagged as report mode CATALL should
honor this (and for me it does).

What version of Natural are you on ?

Are you running CATALL in batch or interactively ?

Hi Wolfgang,

Sorry for not giving you more details. Yes, it is batch mode on MF NAT427.


this does not repro for me with NAT427-sp2 on z/OS v1.11.

  1. Create 2 programs: one Reporting Mode & one Structured Mode, and SAVE only.
  2. Natural Security → Modify Library → Programming Mode = R, then CATALL will catalog both programs successfully.
  3. Natural Security → Modify Library → Programming Mode = S, then CATALL gives error NAT1395 Reporting mode of object … not permitted.
  4. Uncatalog & Rename the programs to swap the order in which CATALL compiles them (ie. RM first or SM first) - this makes no difference.
  5. CATALL in Batch and Online behaves the same.
    Q1) Perhaps there is something “special” about your program or environment?
    Q2) Does this happen for all Reporting Mode programs or just one ?
    Kind regards,

Hi Peter,

I am receiving the error NAT0623. The library and the program have been already created before using catall. I am not using NSC for this process at this moment. If I access the libary, edit the program, change to SM=OFF and try to catalog the objetct, it is ok. it happens not with one object but several of them. I am trying to catalog (catall) almost 100 libraries, and it is impossible to get objects with NAT623, edit them, and to catalog each one of them.

I think that the best option is to do it in 2 steps: catall using globals sm=off, and then catall using globals sm=on.

I noticed that when the object is already cataloged, the error doesnt occurr.


Are you using the STOW or the CAT option on your CATALL ?

Not that it does make any difference for me, both work find, curious anyway though.

You’ll have to open a support incident for this, I guess, as it doesn’t appear to
easily reproduce.

Hi John,
OK I can reproduce your problem.
When GLOBALS SM=ON by default (as you said in your initial entry) …

  1. In the program editor:
    If a Reporting Mode program contains a DEFINE DATA statement (to declare a global data area) then you will get the NAT0623.
    If there is no DEFINE DATA then you will get a NAT1395 error instead.
  2. with CATALL, I always get a NAT1395 (never the NAT0623).
    So the “solution” is to set GLOBALS SM=OFF before you start the CATALL.
    Kind regards,

Hi Peter,

thank you and I appreciate your attention on this issue.


Still can’t reproduce, even when I set GLOBALS SM=ON before starting the CATALL.

Are you in a NSC environment ?

I found out the cause of the error NAT0623. The software that controls Natural objects version, it loads the objects always as structured mode, even if the object is in report mode. we need to fix it before.