Can't purge data within InternalDataStore/Elasticsearch

Background

What product/components do you use and which version/fix level are you on?

webMethods API Gateway 10.3 - yes I know, super old

Is your question related to the free trial, or to a production (customer) instance?

This is a production instance

Have you installed all the latest fixes for the products and systems you are using?

Well yes, but it’s out of support.

Problem

I’m fighting with this API Gateway instance as I spotted that the Elasticsearch indexes keep increasing dramatically and I don’t see a way to limit the size somehow. I’m checking the size using the /_cat/indices resource on Elasticsearch directly.

The rollover feature is not in this product release, yet. So I tried with a scheduled script which triggers a purge using the REST API (DELETE/rest/apigateway/apitransactions) - but that doesn’t seem to do anything. I then tried to purge using the UI (Administration > Manage data > Archive and purge), like this:

image

but that doesn’t seem to do anything either, surprisingly. No error messages in IntegrationServer’s server.log and error.log.

Question

So - am I missing something painfully obvious? Isn’t this supposed to clean the InternalDataStore’s indexes?
Maybe there is a bug - do you know of a way to manually clean old data using the Elasticsearch API directly?

Thank you and kind regards, Christoph