Cannot enable JDBC Connection in 64 Bit Solaris.

Hi all experts,
I have this issue where I cannot enable my jdbc connection.
The IS IS 7.1 and OS IS Solaris.
JVM 1.5 64 Bits,
I have read the PDF, searched wmusers & advantage with not a whole lot of luck.
I have the references to the libraries in the classpath,
But for some reason when i try to enable it i get slapped or smacked with this, I have tried the 64 Bit libraries of the Oracle 10G and I have tried 32 Bit ( yeah i know stupid to try 64 JVM, with 32 Bit libraries…but i just wanted to see if it worked !!!) but in vain.

[ART.118.5042] Adapter Runtime (Connection): Unable to enable connection resource USAA_Arch_Util_DBConnections:Oracle_webmethods.

[ART.118.5063] Adapter Runtime (Connection): Unable to start connection USAA_Arch_Util_DBConnections:Oracle_webmethods: after 1 attempt(s).
no ocijdbc10 in java.library.path

Experts this is a urgent issue.

Any help would be monumentally appreciated.


I know there is a post that talks about
“no ocijdbc10 in java.library.path”
And i know what it is looking for and i am providing it with that library file , but still for some reason it wont work.
please help experts !

As I understand from this issue,

Check the ocijdbc10.jar file under IntegrationServer/Lib folder. if not copy the file into that folder and restart.

If the jar file is found in different folder, add that folder into webM classpath found in startenv.bat or .sh.

hope this help.


Its a not a jar file.
This has to be references in the
It resides under oracle_home directory.
i tried picking it up using -Djava.library.path but still cannot be read by the jvm.

Its is referenced by LD_LIBRARY_PATH ( which obviously doesnt help)

Experts please suggest
Please note its a 64 bit jvm…and libraries are 64 bit too