Canbt remap bizdocToRecord boundNode

Help, please.

I’m running on MS Win2K Server, IS SP1, FP2 / TNS v6.1 Fix15. I have also reconfigured to run Sun’s JDK 1.4.2_08.

I’ve just moved from a v4.6 env to v6.1.

I’m sending documents to TN, it receives them fine, and fires the associated Flow service OK.

Once in my Flow service, I execute I then map the boundNode output to a doc reference of the appropriate doc type.

Everything is OK at this point. I’ve stepped through the code in Developer and both the boundNode and the doc ref have the proper content.

This is where I’m going nuts.

I map one of the text sub-elements from the doc ref to a text variable and when I run Developer, that variable doesn’t show up – which, I’m assuming, means it had nothing mapped into it.

I’ve quadruple checked: the source element has content.

This is the same thing I have done on TN v4.6 in the past and it has worked fine but I can’t, for the life of me, get this to work on TN v6.1.

“The weird thing”: there is one oddity that I can see that I couldn’t find referenced anywhere. I don’t know if it’s relevant or not.

In my document type definition (to which I map my output boundNode), the text sub-elements all have a vertical double cross near the upper right corner of the “Abc” icon. These double crosses don’t display when I step through Developer but they show up when I look at the doc type, itself, in Developer.

Any help would be greatly appreciated. I’m going crackers.

Thanks, all.

The “vertical double cross” indicates that the field has content type defined for its properties. For your symptom this most likely isn’t related.

One bug I’ve seen in developer is that in some instances a map line between fields sometimes gets an index added to it inexplicably. Check the map step that maps the fields. If it’s blue, then it has an index defined and it probably shouldn’t. I think I’ve narrowed this bug down to steps that were once in a loop (with no index) but are now no longer in a loop–and IS/Developer “helpfully” added an index of 0.

What data type is the source field? A string?


Thank you. I checked for an index on the mapping and, just to make sure, I deleted the mapping and redid it but still have the same (lack of) results.

I have stripped this Flow service down to the bare bones so there’s pretty much only the bizdocToRecord Flow call and the subsequent MAP operations. They’re nested inside a SEQUENCE try/catch block.

Yes, the datatype of the source is just a simple string (as is the target) but the source string is a child of a document which, itself, is a child of another document (and so on and so on).

Thank you again.

  • Pete Ryan

Might there be a capitalization or some “similar-looking” character issue? While your doc type might have “FOOBAR” as the field name, the field that is coming in the actual document might be “F00BAR” (zeroes instead of capital o). Is this the only field in the specific structure that has this problem? In other words, are “sibling” fields mapping okay? Might you be able to post the snippet of the portion of an actual document and a screen shot of your mapping step? It’s gotta be something easy but hard to see…


Thank you. That was it. I had created the document from an XML doc and one instance of the doc had the namespace prefix on the parent tag and the other did not.

Thank you for the extra set of eyes.

  • Pete Ryan