Can a Custom Package get corrupted while deploying to other environments.

Hi ,

We recently faced an issue where our custom package is working perfectly fine on current environment, but its failing in other environment where we have deployed using the webMethods deployer. When we compare the package on both the environments it doesnt show any code difference. Can the package get corrupted during the deployment on the target environment.

I have a few below queries, Can you pls help me out with this.

  1. Can a custom package get corrupted while that is getting checked into SVN via some scripts.
  2. Can a custom package get corrupted while using the webMethods deployer to deploy a package from one environment to another.


Hi Raveesh,

There are lot Ifs, Buts involved in this scenario.

  1. Yes, I faced. [How you have configured your SVN to check-in check-out your code?]
  2. Never faced. [6.X, 7.X, 8.X].

Any error in build, map, simulation, deployment reports?

Hope other experts share their experiences.


@ Raveesh,

Regarding your first question - I have no comments :slight_smile:

Regarding your second question - When you prepare your deployment build using WmDeployer the report clearly shows if there is any error or unresolved dependencies.

Can you let me know the number of pacakages this is corrupted (if it less for eg., less than 5) you can import them manually from replicate/inbound. If its more then you can use WmDeployer and have an eye on the report (build, simulation)

Other option is try to re-load the package (on the environment that does not work) and see the results.



We have deployed 5 custom packages using Wmdeployer(webMethods 8.2) and deployment report is success, but while testing the custom package in the target env i came to know that one package got corrupted.

After comparing the codes in both the environments there is no code difference.

But if i edit(no changes to the code) the custom package on target environment inorder to regenerate the flow.xml after whcih the custom package works as expected.

Did anybody faced the above issue and is there any root cause.


did you check the server.log of the target after deployment and upon test?

Maybe there was namespace conflict or any other error, which was not detected by Deployer.
Additiionally there might have been a filesystem issue during deployment which caused the problem.

Can you describe a little bit further how you detected that the package got corrupted?
This might help us to determine what exactly happened.

Please also check for Deployer-Fixes as sometimes the Deployer do some weird things which might be fixed meanwhile.


Hi Holger von,

I tested the package on target environment but it not work expected and thrown error.Same package on the source environment worked perfectly fine.
On the target environment i added a simple map step in the package and deleted it just to regenerate the flow.xml.
After this change the package worked as expected in the target environment. No code changes were done for the package in the target environment.


Just a try --Did you reload the package on target server again, to see if that works…?


Even after reloading the package in the target environment it didnt worked.

It worked only when i edit and save the package without any code changes inorder to regenerate the flow.xml.

Hi Raveesh,

Please let us know source IS and target IS JVM versions.


Hi Raveesh,

can you share the error message please?

This will help to identify whats going on here.

Additionally a server log extract of the time frame when the deployment was done is also helpful.