Calling SAP RFC And Not Getting All The Data

Hello,
I’m running WebMethods v4.6 and SAP 4.6C. I have a FM that takes a material number as input and I am trying to get 2 pieces of data back. I’ve created 2 entries in the Export tab and I’ve also created an entry in the Tables tab to try to get the data returned to WM. Testing in SAP shows all values are populated correctly. In WM Integrator, I do the Lookup and have it create the map for SAP BC --> SAP. When I test either here in the integrator, or in the WM Developer the only values that are returned are values that were set like: "move ‘STCC’ to t_stcc-funcname’. The commands that move a variable, “move wk_stcc to t_stcc-stext” do not contain any data when run from WM. I’ve tried to add a map step b/f the sap.map:outbound in order to initialize the values, but that hasn’t helped either. Any ideas on what I should do?

Thanks,
JC

Activate the “RFC Trace” for that SAP Alias and reproduce the error. Perhaps this will give further clues. (RFC traces are written to the webMethods/Server directory.)

Regards, Lanzelot

Goto your listener connection and check Unicode Listener is set to Yes or not… Once we faced this issue and set to this field to “Yes”… It worked !!!