Built In Service Not Compiled, Url Alias Disabled


In my dev environment have an issue cant look url aliases in admin page.

and when i check log i have this error messege

[ISS.0026.9102] Service ‘wm.server.httpUrlAlias:listAlias’ is not operational. To run this service, first recompile the Java source.

can we recompile built in service in wm root?

what i suppose to do?


@dekaa_momon Lame answer, but did you try a restart? If it happens for a custom java service, that’s different. But for a built-in service? All wmpublic services are java. Do you see this happening for other java services as well, or happens to be only for this service? I just think the install has got some problem. Have latest patches ( or atleast some patch, not a GA version ). In extended settings there is one watt parameter that holds jvm path. Cross check if it has got right path.


1 Like

wrapper.java.command - this one is under /profile//configuration
watt.server.compile - this is server configuration parameters


services in WmRoot and WmPublic are available precompiled in some internal jar files and do not have the java source explicitly available for recompile.

First of all stop and restart the affected instance as Senthil has suggested. Check the wrapper.log and server.log for any loading error messages.
If this does not help you can try to reinstall your IntegrationServer.
Finally, you should open a SupportTicket with SAG to get this analyzed.


I seem to remember that many years ago we had something like this. At the time it could be solved by adding the path to the compile command in the watt.server.compile setting via the IS UI.

1 Like

Reloading the WmPuclic package might solve your problem. If the package doesn’t reload for a very long time, it might be stuck on load, if that’s the case restarting the integration server is probably the thing you can do. I agree on creating a ticket. If creating a ticket is an option, you should create a ticket so that it will be fixed permanently (assuming its a bug, not a user error).

hi all,

thanks for the aswer
i try to reload and retart IS but nothing happen.

the issue is already solved by copying java class file from another instance.

sorry for late reply,