Broker to UM 10.3 migration

Hi,

We are doing a broker to UM 10.3 migration. The broker version is 9.6 and it has both basic auth and SSL configured and enabled.
We disabled both of them and ran the ./brokerjndimigration.sh but still get the below error.

Is it because the client group has encryption enabled. Do we also need to disable the encryption for the CG.

If so, is there any other way of handling this?

Exception in thread “main” javax.naming.CommunicationException: [BRN.118.1022] Broker Storage Read Error: Unable to load context WmJmsNamingContext from: Broker::JmsNaming::WmJmsNamingContext. Broker Exception: Cannot connect to the specified client group because that client group requires an encryption level higher than you are using. [Root exception is No Permission (109-2370): Cannot connect to the specified client group because that client group requires an encryption level higher than you are using.
]
at com.webmethods.jms.naming.BrokerContextStore.loadBindings(BrokerContextStore.java:457)
at com.webmethods.jms.naming.WmJmsNamingContext.(WmJmsNamingContext.java:114)
at com.webmethods.jms.naming.WmJmsNamingCtxFactory.getInitialContext(WmJmsNamingCtxFactory.java:31)
at javax.naming.spi.NamingManager.getInitialContext(NamingManager.java:684)
at javax.naming.InitialContext.getDefaultInitCtx(InitialContext.java:313)
at javax.naming.InitialContext.init(InitialContext.java:244)
at javax.naming.InitialContext.(InitialContext.java:216)
at com.softwareag.num.migration.BrokerJNDIMigration.getBrokerJNDIEntries(BrokerJNDIMigration.java:426)
at com.softwareag.num.migration.BrokerJNDIMigration.migrate(BrokerJNDIMigration.java:42)
at com.softwareag.num.migration.BrokerJNDIMigration.doOperation(BrokerJNDIMigration.java:739)
at com.softwareag.num.migration.BrokerJNDIMigration.main(BrokerJNDIMigration.java:768)
Caused by: No Permission (109-2370): Cannot connect to the specified client group because that client group requires an encryption level higher than you are using.

It seems your client group has “Encryption” checked. But, client is not using enabling it, so plain-text is getting used.

One of following should resolve the issue for you:

  1. Set “com.webmethods.jms.naming.encrypted=true” for your JNDI
  2. Uncheck “Encryption” in your client group. Default client group is “admin”.
  3. Use latest client jars (apply Broker Java API fix), that enables encryption by default for all SSL connections

Correction. Only 2 will work. Uncheck “Encryption” setting on client group (default admin).

I skipped over the detail that you had already disabled Basic Auth and SSL on server.

Hi Sandeep,

Yes, I disabled the encryption check box for the “admin” client group and I was able to complete the migration.

Thanks,
Supriyo