Broker SSL Identity and ACLs

I am using webMethods Broker 7.1.2 and My webMethods 7.1.2.

I am trying to configure the Broker for SSL and also configure Broker ACLs.

After I assign an SSL identity to the Broker Server, I can no longer access the ACL tab in the Broker Server Details page of My webMethods.

After assigning an SSL identity to the Broker Administrator user interface in My webMethods I get the following error when I click on the ACL tab:

Broker server connection is not using SSL, possibly because of a mismatch in SSL identity. Set the correct identity on Broker server and/or Broker Administrator and return to this page.

On the Configuration tab of the Broker Server Details page, it says “SSL is configured and working”, however it also says “Identity not recognized”.

After uploading the keystore and truststore files, here are the steps I am following:

First, assign an SSL identity to the Broker Server

  1. In My webMethods: Messaging > Broker Servers > Servers.
  2. Click the link to the Broker server
  3. Click the SSL tab
  4. Click Change Configuration
  5. Click Local Keystore tab
  6. Select Keystore Type “PKCS12”
  7. Type in Cipher Suites “All:eNULL”
  8. Type in SSL Keystore Password
  9. Click Get User Names
  10. Click Apply

Then assign an SSL identity to the Broker Administrator user interface

  1. In My webMethods: Messaging > Settings.
  2. Click Identity tab
  3. Click Change Identity
  4. Type in SSL Keystore Password
  5. Click Get User Names
  6. Click Connect

Does anyone know what this error means and how I can resolve it?

P.S. I can attach my keystore and truststore files if that would help

Were you able to fix this problem? I am having similar problem (rather worst than yours). In my case when i supply information about identity, it does not say anything. Everything looks ok. But when i go to ACL tab…it says "Not accessible. Broker administrator identity required " although i just assigned broker admin identity.

When i see broker log i see this error "No Permission (109-1382): Operation failed because permission is denied. This operation requires administrative permissions. "

Let me know if it looks familiar.

Thanks

Haroon

Were you able to fix this problem? I am having similar problem (rather worst than yours). In my case when i supply information about identity, it does not say anything. Everything looks ok. But when i go to ACL tab…it says "Not accessible. Broker administrator identity required " although i just assigned broker admin identity.

When i see broker log i see this error "No Permission (109-1382): Operation failed because permission is denied. This operation requires administrative permissions. "

Let me know if it looks familiar.

Thanks

Haroon

I have not yet been able to fix this problem, so currently we have decided to use the Broker with SSL disabled.

I will raise a service request if I do not receive any advice in this forum, and once the service request is resolved i can post my findings here.

Please let me know if you find a way to fix this problem.

I was unable to fix this issue and found out that Webmethods 7.1.2 does not have this issue. So we upgraded to 7.1.2 and successfully setup SSL on broker, IS and MWS.

I have the similar issue with webmethods 8.2…does anybody knwo how to resolve this?
I have uploaded PKCS12 keystore and JKS truststore…I click on setting and try to get the username by entering password …i do not get any username …eventhough keystore has keypair…as a result Broker Administrator Identity is not set and canot proceed with ACL part for setting up Broker SSL.
I would appreciate any assistance…