bizDoc attributes not getting captured


I couldn’t see the attributes which I’m trying to capture in the bizDoc.

  2. map step where I set the attribute with value
  3. routeBizdoc

Please let me know where I’m doing the mistake.


How do you set the attribute? You got to use two services to set and update the attribute inside bizdoc. - you could call this ‘n’ number of times to add one or more attributes in bizdoc - this updates all the attributes info in the TN database.


What are you trying to retrieve/extract or set/update attributes?

Do you see the bizdoc in the pipeline?


Hi RMG, Senthil,

I see the bizdoc in pipeline, where I tried both using map step (setting the Attributes) and even i tried using “” service I couldn’t see the attributes in “attributes” tab.

Have you created new attribute already via TNC or programmatically wanted to create one and update value to see it via Transaction Analysis for that document?


No I didn’t create any attribute via TNC or programmatically.

Just I’m trying to display the InvoiceNumber which I see in xml file. In my beta/prod its working fine and not in my local machine. It looks like something I’m missing in my local machine settings.


may be can you cross check with ur env…


After your query “did I create any new attribute in TNC” verified in documents. By that,

  1. First, we need to do “Add document attributes” using MWS
  2. Second, we can get the custom attributes in 2 ways
  • Just by setting the “attributes” in the bizdoc in the flow service OR
  • In the “document Type” >> Extract >> Attributes to Extract >> we can set the attributes with query

This solved my issue. Thanks RMG and Senthil in helping me.


Yes you are in the right direction…your welcome: