Basic FTP Question

Hi All

I have a basic FTP question. It looks like I had been stuck somewhere. I had done this in the past but dont realize now where I am going wrong.

  1. I had created an ftp port 8021, changed access mode to allow by default.
  2. Disabled the firewall just to make sure that its not messing things up.
  3. Created a new user ‘Alice’ with password ‘alice’ and made her part of Administrator group
  4. Started a command prompt and started ftp and gave ‘open localhost 8021’

The server responds
Connected to earth.
220 earth:8021 FTP server (webMethods B2B version 4.6) ready.
User (earth:(none)): Alice
Connection closed by remote host.

I can see an entry in the session log with an age of 43904 msecs for this session. But I get ‘Connection closed’ in the prompt also note that I did not get an option to supply the password.

I had tried command prompt ftp since the FTP functionality not work from the developer as well. Even though I did not get a chance to provide the password from the prompt I had set it in developer. When I try to take a local file and ftp it into another directory the exception is thrown as

com.wm.net.ftpCException: [B2BCORE.0064.9005]

The server log now set at log level 10 says

018D20 [B2BCORE.0064.0020] host: earth port: 8,021 User ID: Alice
018D21 [B2BCORE.0064.0021] Successfully connected to host: earth port: 8,021
018D22 [B2BSERV.0063.0001] Create 64646464f70d0dfa00000240
018D23 [B2BCORE.0064.0024] <- 220 earth:8021 FTP server (webMethods B2B version 4.6) ready.
018D24 [B2BCORE.0064.0026] -> USER Alice
018D25 [B2BCORE.0049.0004] Branch : index=1 depth=1
018D26 [B2BCORE.0049.0019] Branch null: no expressions evaluated true, but default child found
018D27 [B2BCORE.0049.0005] Invoke $default: index=1 depth=2
018D28 [B2BSERV.0048.9999] [B2BCORE.0064.9005]
018D29 [B2BSERV.0056.0003] Unable to send mail. Illegal address
018D2A [B2BCORE.0049.0004] Branch : index=1 depth=1
018D2B [B2BCORE.0049.0019] Branch null: no expressions evaluated true, but default child found
018D2C [B2BCORE.0049.0005] Invoke $default: index=1 depth=2
018D2D [B2BSERV.0048.9999] [B2BCORE.0064.9005]

I had tried this with both 4.6 and 6.5 IS and both behaves the same. That makes me feel like I am making some stupid mistake. Would any one of you shed some light into this pls.

Thanks and regards

Thahir

Looks like the service you are invoking with your FTP contains a bug on a Branch statement. Disable everything in the service and add a pub.flow:tracePipeline statement at the top, then retest.

HTH,

Mark

Mark

I dont think I am reaching to the service yet.

While I try to connect from the prompt I need to log into the system and cd to the service before I could submit a document. But here I am not even able to log to the system. The system already tells me that ‘Connection closed by remote host’.

Just wanted to remind you that I tried to use the command prompt since the developer was not working the way I expected so I just wanted to check that FTP was working.

Also in developer there is no service that accepts an inbound ftp. Its an outbound ftp just taking a file from the intergration server and moving into another place. This was just a test service.

Hope I am making myself clear.

Thahir

I think I know your issue. The command usage is trying port 21 instead of 8021. Try this…

ftp
open <port#> Example: open localhost 8041
usr:
pwd:

Please post what you get…

Rocky

I had been using the ftp with the port command all the time. In any case this is the output.

D:>ftp
ftp> open localhost 8021
Connected to earth.
220 earth:8021 FTP server (webMethods B2B version 4.6) ready.
User (earth:(none)): Alice
Connection closed by remote host.
ftp>

Thahir

Hi Thahir,
Please ensure that the port has been enabled on the server.
I am getting a similar error when there no service listening on the specified port
ftp> open sea 4711
ftp: connect: A remote host refused an attempted connect operation.

Yogesh

The port is enabled and as I mentioned in the first post I can even see an entry in the session log. The server is asking for the user name but does not ask for the password and close the connection.

Thahir

It looks to me like there are two separate problems here. Command-line FTP could be failing for reasons completely unrelated to your problem in Developer. It does look like you’re establishing a session in Developer. Try Mark’s suggestion and see what you get.

Tim

Hi Guys

Thanks for the replies. I had sorted out the problem. Well it was not firewall but it was one of the new softwares from McAfee.

McAfee recenlty updated their ‘Internet Security Suite’ with few more products and it started blocking many services, most of my problems were solved by configuring firewall, so for webMethods problem I disabled firewall.

This did not help, so I did a ‘clean boot’ thus avoiding any services to come up and I ran an IS Server and everything worked fine.

I contacted the internet chat support of McAfee and they gave me the best advice that anyone can give me. Uninstall one by one of our software till the problem is fixed. I had such a poor support from them such that I had already placed an order to switch to NODE32. I guess it gets approved fast. I had been told that its much faster than McAfee.

Now since I din have any choice, I started uninstalling one by one of their product suite, when I uninstalled the third one called the ‘Spam Killer’ things started working normal.

HTH someone someday

:slight_smile:

Thahir