BAM fact table not created correctly during environment depl

Hi,

I am trying to set up an Optimize environment and I’m running into some trouble when trying to Deploy a new environment in myWebmethods. Here are the steps that I do:

  1. Install webMethods product suite 7.1.2, IS, myWebmethods, Optimize, Broker, Central Configurator etc.
  2. Run dbConfigurator and create ALL tables using version 7.1.2
  3. Configure the Broker Server and Broker in myWebmethods
  4. Configure the WmOptimize package by going into the IS Administrator->Packages->management->WmOptimize homepage and then submit the default Broker URL.
  5. Create DB Pool in myWebmethods under Administration->System-Wide->Environments->Database Pool Configuration.
  6. Define the environment in myWebmethods under Administration->System-Wide->Environments->Define Environments with the settings described in the “Central Configuration and Deployment Guide 7.1-4”
  7. I deploy this environment and myWebmethods shows that deployment was successfull after I hit the deploy button.

Here is where I start getting errors in the Analytic Engine log. Here are some of the errors I get:

color=“blue” [AE.EventMapHandler.evntMapHldrPreDeployError] 2009-09-09 16:15:16.578 CEST ERROR: Error pre-deploying event map AnalyticEngineLoad
(OPTIMIZE) [AE.EventMapHandler.evntMapHldrPreDeployError] 2009-09-09 16:15:16.578 CEST ERROR: java.sql.SQLException: [wm-cjdbc36-0007][Oracle JDBC Driver][Oracle]ORA-00955: name is already used by an existing object

(OPTIMIZE) [AE.EventMapHandler.evntMapHldrPreDeployError] 2009-09-09 16:15:17.703 CEST ERROR: Error pre-deploying event map AnalyticEnginePersistence
(OPTIMIZE) [AE.EventMapHandler.evntMapHldrPreDeployError] 2009-09-09 16:15:17.703 CEST ERROR: java.sql.SQLException: [wm-cjdbc36-0007][Oracle JDBC Driver][Oracle]ORA-00955: name is already used by an existing objec

(OPTIMIZE) [AE.TransactionWrapper.UnknownKey] 2009-09-09 16:18:17.296 CEST ERROR: Aborting transaction due to exception
(OPTIMIZE) [AE.TransactionWrapper.UnknownKey] 2009-09-09 16:18:17.296 CEST ERROR: com.wm.dd.jdbc.base.BaseBatchUpdateException: [wm-cjdbc36-0007][Oracle JDBC Driver][Oracle]ORA-00904: [/color]“PERSISTENCEQUAL_DIM[color=“blue”]”: invalid identifier

(OPTIMIZE) [AE.AggregationPopulator.UnknownKey] 2009-09-09 17:15:01.515 CEST ERROR: java.sql.SQLException: [wm-cjdbc36-0007][Oracle JDBC Driver][Oracle]ORA-00904: “FACT”."[/color]CONNECTION_STAT_FACT[color=“blue”]": invalid identifier

(OPTIMIZE) [AE.Query.UnknownKey] 2009-09-09 16:25:40.296 CEST ERROR: Unable to perform query: sql: SELECT BAM_FACT_ANALYTI_V1.Weight_FACT, ‘1’ AS Weight_FACT_INTERVAL, ‘1’ AS Weight_FACT_COUNT,BAM_DIM_ANALYTI_V1.LogicalServerName_COL AS BAM_DIM_ANALYTI_V1_Analyt,BAM_DIM_ANALYTI_V1.BAM_DIM_ANALYTI_V1_id,BAM_FACT_ANALYTI_V1.entry_time AS TIME,BAM_DIM_INTERNA_V1.Name_COL AS BAM_DIM_INTERNA_V1_Intern,BAM_DIM_INTERNA_V1.BAM_DIM_INTERNA_V1_id FROM BAM_DIM_INTERNA_V1,BAM_FACT_ANALYTI_V1,BAM_DIM_ANALYTI_V1 WHERE BAM_FACT_ANALYTI_V1.Analytic_Engine_DIM = BAM_DIM_ANALYTI_V1.BAM_DIM_ANALYTI_V1_id AND BAM_FACT_ANALYTI_V1.ENTRY_TIME = ? AND BAM_FACT_ANALYTI_V1.InternalMonitor_DIM = BAM_DIM_INTERNA_V1.BAM_DIM_INTERNA_V1_id, bind variables: [1252506300000, 1252506000000] for EventQuery{dimensionalPath=HierarchySetting{dimensionName=‘InternalMonitorQualifier’, dimensionVersion=1, dimensionAttributeName=‘Name’, children=’[HierarchySetting{dimensionName=‘AnalyticEngine’, dimensionVersion=1, dimensionAttributeName=‘LogicalServerName’, children=’[]’, left=‘null’}]’, left=‘null’}, queryInterval=QueryTime{startDate=Wed Sep 09 16:20:00 CEST 2009, endDate=Wed Sep 09 16:25:00 CEST 2009, aggregate=true, interval=300000}, queryables=[Weight], queryFilters=[], aggregation support=NONE}

(OPTIMIZE) [AE.Query.UnknownKey] 2009-09-09 16:25:40.296 CEST ERROR: java.sql.SQLException: [wm-cjdbc36-0007][Oracle JDBC Driver][Oracle]ORA-00904: “BAM_FACT_ANALYTI_V1”."[/color]WEIGHT_FACT": invalid identifier

These errors regarding invalid identifier are thrown every 8 seconds.

Something is clearly wrong with the BAM_FACT_ANALYTI_V1 table. The event maps AnalyticEngineLoad and AnalyticEnginePersistence are not deployed correctly but I can see that the events exist in myWebmethods under Administration->Analytics->KPIs->System data.

When looking into BAM_FACT_ANALYTI_V1 I can see that the columns WEIGHT_FACT, CONNECTION_STAT_FACT, PERSISTENCEQUAL_DIM are missing which is also indicated by the error message. The entire BAM_FACT_ANALYTI_V1 table is unpopulated.

I have tried a fresh product install and DB install and I always run in to the same errors. Any suggestions to what I should do?

I should mention that I have been using the same DB user (SYSTEM) throughout the entire product suite without specifying any DB schema.

I tried this on two virtual machines, one running WindowsXP+OracleXE 10G and the other one with CentOS(Red Hat)+OracleXE 10G. Same error on both.

Any ideas on what I could have missed or how the BAM_FACT_ANALYTI_V1 can be created successfully after an Environment deployment? When looking into other webMethods installations I can see that columns WEIGHT_FACT, CONNECTION_STAT_FACT and PERSISTENCEQUAL_DIM dont exist in BAM_FACT_ANALYTI_V1 but they do exist in BAM_FACT_ANALYTI_V11, BAM_FACT_ANALYTI_V12 BAM_FACT_ANALYTI_V13 which are tables that I dont have on my installation.

I cannot determine the real problem but… consider this:

I have found the DCC Database Component Configurator version is very important (sometimes).
What does your DCC About say?
I have Optimize for Infrastructure installed 7.1.2 using this DCC version “.86” release. I don’t know the latest release.

About ==>
webMethods Database Component Configurator version 7.1.2.0.86 20090224.1.dcc_712

In our O4I Oracle database we have BAM_FACT_ANALYTI_V13 and V12 and V11 and V1. I have only run two successful MDPurges.