Authentication to be implemented in SoAP API in API GW

Hello All,

API Gateway 10.5 version with latest fixes Version 10.5.0.8.317
while invoking the API in SOAP UI getting below error message, when the global policy is activated or enable.
API Gateway encountered an error. Error Message: Unauthorized application request.

If i deactivate the global policy my api’s are working fine

Screenshot of global policy
image

Could anyone share your thoughts.

Hello Pradeep,

As per the policy enforcement order for this stage, the global policy takes precedence over other policies. So the user/access credentials you are using to invoke the API from SoapUI aren’t authenticated by the settings configured in Global policy.

Please validate the application credentials to access API and then use the correct ones, which works with Global policy.

Please share your findings.

Regards,
Firoz N

Thanks Firoz for your response.

In identify and access the we configured as registered applications and In registered applications Identifiers are missing.

When i add the identifiers, issue has resolved.

Thanks for the community.