Audit Exception: table or view does not exist problem

I just reinstalled the Webmethods IS, then in Admin Panel, when I clicked all links below Logs menu (except Logs->Server), I got this big red error message:

com.wm.app.audit.AuditException: [BAA.0002.0000] Wrapped Exception: java.sql.SQLException: [wm-cjdbc36-0007][Oracle JDBC Driver][Oracle]ORA-00942: table or view does not exist

[COLOR=Red]What does this mean? What table doesn’t exist? The error message was not clear.

I installed the IS by using external database, does that mean I have to create a table for audit?
[/COLOR]

Hi,
Goto IS Admin > Settings > Logging… You can find the Logger List, and what is the destination (whether database or file).

If it is Database, you have to configure IS Core Audit in JDBC Pools section…

Change it to File, and you will not see this error appearing…

-Senthil

Hi,

I can’t find the destination info in Logging page. This is how it looks like from my admin panel:

hi bromo,

Your IS Core Audit should already set to database else you wont receive the error message above.
Now you need to make sure you have done the steps below.

  1. Create database component for isCoreAudit and isInternal.
    You can create those tables by using Database Component Configurator.

  2. Create JDBC pool alias definition and associate your JDBC connection pool to IS Core Audit and isInternal under functional alias definition.

Hi,

The above one is correct. You need to create one jdbc pool with alias name and shuld run create25 file in IS folder with Database Component Configure tool..

See attached…

Thanks, you’re right. The process of #1 is really painful though. I tried many times with errors.

The Connection URL is problematic and not user-friendly, they should use textfield for each field (address, port, sid/servicename, etc) instead.

I checked “Create Tablespace and Database User” option, so I entered admin ID and password, but I got error “ORA-28009: connection as SYS should be as SYSDBA or SYSOPER” at run. It turned out that I have to add “sysLoginRole=sysdba” in URL.

@Senthil Kumar G:
It seems your Logging page is different from mine. What’s your webmethods IS version? Mine is 7.1.3.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.