API Gateway Load Balancer Config

Hi,

We have configed an API Gateway cluster with 2 nodes, one intranet hostname of one node is VPSZ-API-Gateway01 and another hostname is VPSZ-API-Gateway02, and we use load balancer Nginx for the API Gateway cluster, the external URL for the nginx will be https://api.jusdaglobal.com:443/gateway, on API Gateway Administration load balancer configuration, we have configed an HTTPS url : “https://api.jusdaglobal.com:443” to match the URL of nginx, but after creating a new API, the Gateway endpoint is still intranet host name “http://VPSZ-API-Gateway01:5555/…” instead of nginx url “https://api.jusdaglobal.com:443”, we hope that the url exposed by the API in the Gateway endpoint is consistent with the url of nginx, what should we do.
The screenshots of the API and Gateway Administration load balancer configuration are attached for your reference, thanks.

Kelley

attach screenshots.


Hi,

This doesn’t look to be the right behavior. What is the product and fix version?

Can you please relogin once and check it

Hi, Praveen:

The API Gateway version is 10.5, and we have installed fix YAI_10.5_Fix4, IS_10.5_Core_Fix3,and CEL_10.5_Fix1 as attached.

Kelley

Hi, Mohammed:

It’s same issue no matter restarting API Gateway or relogin.

Kelley

Hi Kelly,

You have added LB for https and you didn’t select HTTPS in Policy -> Transport -> Enable HTTP / HTTPS.

Option 1: Add LB for HTTP protocol
Option 2: Enable HTTPS protocol in Policy -> Transport -> Enable HTTP / HTTPS

Hi, Mohammed:

When we enabled HTTPS protocol in policy, this problem was solved,thank you very much.

Kelley

Hi, Mohammed:

When we only enable HTTPS protocol in policy, the gateway endpoint URL of the API has only one HTTPS URL like “https://openapi.jusda.com:443/…”, which is exactly what we want, but when we call the API, an exception of “Transport protocol not supported…” will be reported. In this case, whether the HTTP protocol must be enabled in the policy? But the HTTP protocol is not enabled on nginx, we do not want to expose the service of HTTP protocol, how can we solve this problem.

Kelley

Please invoke the gateway endpoint using HTTPS instead of HTTP as you configured HTTPS only.
Or you can add the HTTP protocol in policy

Hi, Mohammed:

Noted ,thanks.

Kelley