After deleting all the measurement entries "c8y_SupportedMeasurements" and "c8y_supportedSeries" are not cleared. Want to delete the fragment and series names in those managed object attributes too

What product/components do you use and which version/fix level?

cumulocity

Are you using a free trial or a product with a customer license?

Customer license

What are trying to achieve? Please describe in detail.

After deleting all the measurement entries, the “c8y_SupportedMeasurements” and “c8y_supportedSeries” are not cleared inside managed objects. Want to delete the fragment and series names in those managed object attributes too if all the measurements have been deleted in that device. I understand that these are cumulocity’s built-in objects inside managed object. But how to clear that as well? Kindly anyone help.

Do you get any error messages? Please provide a full error message screenshot and log file.

No Error.

Have you installed latest fixes for the products

Supported measurements is an array. Have you tried passing an empty array?

{
  "c8y_SupportedMeasurements": []
}

“c8y_SupportedMeasurements” and “c8y_supportedSeries” are refreshed asynchronous, as far as I remember 2 times a day. Unused c8y_SupportedMeasurements and c8y_supportedSeries are removed automatically.

Yes, I have tried both

“c8y_SupportedMeasurements”:

and

“c8y_SupportedMeasurements”: null

I am looking to delete the entries manually through PUT API. But am not able to do which is needed for logic to create a new managedobject attribute with an entirely new set of fragment and series names.

May be as you say, I will check if the managed object’s inner attributes are deleted if all measurements are deleted for a device and unused. But if you find any to delete it explicitly please pass you comments.

“c8y_SupportedMeasurements” and “c8y_supportedSeries” are automatically created when you create a new measurement e.g. with:
POST {{baseUrl}}/measurement/measurements

body:

{
    "source": {
        "id": "{{managed object id}}"
    },
    "type": "abc",
    "time": "{{$isoTimestamp}}",
    "c8y_Steam": {
        "Temperature": {
            "value": 95,
            "unit": "C"
        }
    }
}

I don’t know another way to delete unused “c8y_SupportedMeasurements” and “c8y_supportedSeries” than to wait until the background functionality has removed it.