Admin console not accessible [Urgent]

Hi,

Does anyone encountered the issue on admin console not accessible in webMethods?. We are facing problem in accessing the same during certain times. Sometimes, admin console UI comes up automatically after some period of time. But, few other times we have restarted the server to access the same. Pls let me know if anybody would have encountered similar issue.

Thanks and Regards,
Shrirksha A N

What IS version 8.2.2 or 7.x?

IS version : 7.1.2

Create additional ports for the IS and try to access the Admin from those ports when the issue is happening. This will isolate the problem to the port, if you are able to access the Admin console from other ports.

Cheers,
Akshith

Yes another option as above:

If issue doesn’t get resolved by creating another port then issue could be due to JDBC pools or database where JDBC pools are created. Try pointing your JDBC pools to database where some other IS is having JDBC pools and working fine.

Since version 7 there is a diagnostic port available, which has a guaranteed thread pool, so if the problem is due to insufficient threads, you can still get access.
Sometimes IS does not automatcally goes to the WmRoot home ,which is the admin console. Try adding /WmRoot after your server adress, e.g.
http://server:port/WmRoot

YEs if not try with http://server:9999/WmRoot diagnostic port in 8.x default:

This is very common issue. There are can be multiple reasons that response time of admin is slow or in worst not accesible. Common case are memory and thread problem. If its not accesible only option is to login through diagnostic port which would create heap dump that you can analyse. But there is little you can do after login through diagnostic port because access mode of this port is Deny by default with only few admin service accesible. Also its an good idea to allocate more thread to diagnostic for emergency situation.

HTH

Hi,
Today i faced the same issue.
I’m unable to access the admin console when i disabled the default package and restarted the server.

I did not find any issue in server logs also. Even server log says that server is up and running And i’m able to connect to the server using WmDeveloper. But i’m unable to access the admin console.

After seeing this thread, i run the server console using http://server:port/WmRoot and i am able to see the console. Thank’s for that.

After that i enabled the default package and restarted the server. And now i’m able to run server console using http://server:port/ itself.

But my question is, what kind of settings i have to do in order to run the server console using http://server:port/ even after disabling the default package…??

Thanks in Advance

Thanks and Regards,
Punith Reddy.T

You can restart the server by giving -port port number that will automatically create a port for you…you can open the the admin page by using that port

Hi savanigadda,
Thanks for your quick reply.

As you suggested, i created a new port 5556 and enabled it.
And then i restarted the server.

But even now also, i’m not able to run the IS console using
http://localhost:5555/ or http://localhost:5556/
(Please note, my default package is diabled)

And i’m able to run the IS console using
http://localhost:5555/WmRoot or http://localhost:5556/WmRoot

I think, when i diable the default package, the ISconsole page is missing some link to WmRoot.
That’s the reason it’s not able to open ISconsole on its default link.

I just wanted to run the ISconsole on its default link like
http://localhost:5555/ or http://localhost:5556/
even after disabling the default package…!!

Thanks and Regards,
Punith Reddy.T

Got to install location IntegrationServer/Packages/Default

open the manifest file and edit the below value and save ityes

now try to restart the server and see…

Hi savanigadda,
Thanks for your reply.

what i understand with your suggestion is, this change in manifest file will enable the default package.

If it so, I just wanted to run the ISconsole on its default link like
http://localhost:5555/ or http://localhost:5556/
even after disabling the default package…!!

Thanks and Regards,
Punith Reddy.T

why do you want to disable the default package?

Hi reamon,

At first, i designed my code in the default package. After that i decided to, make my code as a template. so i designed the same code, in a new package(say A).

To have a clarity in, from which code i’m getting the o/p, i disabled entire default package.
(we have some other ways also to do this like disabling the code prasent in the default package, unlike disabling the default package itself, but i have taken this option)

And, I finout the solution to see the IS console even after disabling the default package using http://localhost:5555/WmRoot with the help of WmUsers.

But my question is,
why we are not able to run the console on http://localhost:5555/ when we diable the default package …??
What is the relation between default package and this console address…??
Is there any way to run IS Console on http://localhost:5555/ after disabling the default package…??

Thanks and Regards,
Punith Reddy.T